Security update for dovecot23

SUSE Security Update: Security update for dovecot23
Announcement ID: SUSE-SU-2019:2514-1
Rating: important
References: #1133624 #1133625 #1145559
Cross-References: CVE-2019-11494 CVE-2019-11499 CVE-2019-11500
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15-SP1

An update that fixes three vulnerabilities is now available.

Description:

This update for dovecot23 fixes the following issues:

  • CVE-2019-11500: Fixed the NUL byte handling in IMAP and ManageSieve protocol parsers. (bsc#1145559)
  • CVE-2019-11499: Fixed a vulnerability where the submission-login would crash over a TLS secured channel (bsc#1133625).
  • CVE-2019-11494: Fixed a denial of service if the authentication is aborted by disconnecting (bsc#1133624).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2019-2514=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    • dovecot23-2.3.3-8.1
    • dovecot23-backend-mysql-2.3.3-8.1
    • dovecot23-backend-mysql-debuginfo-2.3.3-8.1
    • dovecot23-backend-pgsql-2.3.3-8.1
    • dovecot23-backend-pgsql-debuginfo-2.3.3-8.1
    • dovecot23-backend-sqlite-2.3.3-8.1
    • dovecot23-backend-sqlite-debuginfo-2.3.3-8.1
    • dovecot23-debuginfo-2.3.3-8.1
    • dovecot23-debugsource-2.3.3-8.1
    • dovecot23-devel-2.3.3-8.1
    • dovecot23-fts-2.3.3-8.1
    • dovecot23-fts-debuginfo-2.3.3-8.1
    • dovecot23-fts-lucene-2.3.3-8.1
    • dovecot23-fts-lucene-debuginfo-2.3.3-8.1
    • dovecot23-fts-solr-2.3.3-8.1
    • dovecot23-fts-solr-debuginfo-2.3.3-8.1
    • dovecot23-fts-squat-2.3.3-8.1
    • dovecot23-fts-squat-debuginfo-2.3.3-8.1

References: