Security update for python-SQLAlchemy

SUSE Security Update: Security update for python-SQLAlchemy
Announcement ID: SUSE-SU-2019:2211-1
Rating: important
References: #1124593
Cross-References: CVE-2019-7164 CVE-2019-7548
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15

An update that fixes two vulnerabilities is now available.

Description:

This update for python-SQLAlchemy fixes the following issues:
Security issues fixed:

  • CVE-2019-7164: Fixed SQL Injection via the order_by parameter (bsc#1124593).
  • CVE-2019-7548: Fixed SQL Injection via the group_by parameter (bsc#1124593).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2211=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • python-SQLAlchemy-debuginfo-1.2.7-3.3.1
    • python-SQLAlchemy-debugsource-1.2.7-3.3.1
    • python2-SQLAlchemy-1.2.7-3.3.1
    • python2-SQLAlchemy-debuginfo-1.2.7-3.3.1
    • python3-SQLAlchemy-1.2.7-3.3.1
    • python3-SQLAlchemy-debuginfo-1.2.7-3.3.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • python-SQLAlchemy-doc-1.2.7-3.3.1

References: