Security update for openexr

SUSE Security Update: Security update for openexr
Announcement ID: SUSE-SU-2019:2043-1
Rating: moderate
References: #1061305
Cross-References: CVE-2017-14988
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Desktop Applications 15-SP1
  • SUSE Linux Enterprise Module for Desktop Applications 15

An update that fixes one vulnerability is now available.

Description:

This update for openexr fixes the following issues:

  • CVE-2017-14988: Fixed a denial of service in Header::readfrom() (bsc#1061305).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2043=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2043=1
  • SUSE Linux Enterprise Module for Desktop Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2019-2043=1
  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-2043=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • openexr-2.2.1-3.9.2
    • openexr-debuginfo-2.2.1-3.9.2
    • openexr-debugsource-2.2.1-3.9.2
    • openexr-doc-2.2.1-3.9.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    • libIlmImf-2_2-23-32bit-2.2.1-3.9.2
    • libIlmImf-2_2-23-32bit-debuginfo-2.2.1-3.9.2
    • libIlmImfUtil-2_2-23-32bit-2.2.1-3.9.2
    • libIlmImfUtil-2_2-23-32bit-debuginfo-2.2.1-3.9.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • openexr-2.2.1-3.9.2
    • openexr-debuginfo-2.2.1-3.9.2
    • openexr-debugsource-2.2.1-3.9.2
    • openexr-doc-2.2.1-3.9.2
  • SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libIlmImf-2_2-23-2.2.1-3.9.2
    • libIlmImf-2_2-23-debuginfo-2.2.1-3.9.2
    • libIlmImfUtil-2_2-23-2.2.1-3.9.2
    • libIlmImfUtil-2_2-23-debuginfo-2.2.1-3.9.2
    • openexr-debuginfo-2.2.1-3.9.2
    • openexr-debugsource-2.2.1-3.9.2
    • openexr-devel-2.2.1-3.9.2
  • SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    • libIlmImf-2_2-23-2.2.1-3.9.2
    • libIlmImf-2_2-23-debuginfo-2.2.1-3.9.2
    • libIlmImfUtil-2_2-23-2.2.1-3.9.2
    • libIlmImfUtil-2_2-23-debuginfo-2.2.1-3.9.2
    • openexr-debuginfo-2.2.1-3.9.2
    • openexr-debugsource-2.2.1-3.9.2
    • openexr-devel-2.2.1-3.9.2

References: