Security update for webkit2gtk3

SUSE Security Update: Security update for webkit2gtk3
Announcement ID: SUSE-SU-2019:1850-1
Rating: important
References: #1133291 #1135715
Cross-References: CVE-2019-6237 CVE-2019-8571 CVE-2019-8583 CVE-2019-8584 CVE-2019-8586 CVE-2019-8587 CVE-2019-8594 CVE-2019-8595 CVE-2019-8596 CVE-2019-8597 CVE-2019-8601 CVE-2019-8607 CVE-2019-8608 CVE-2019-8609 CVE-2019-8610 CVE-2019-8611 CVE-2019-8615 CVE-2019-8619 CVE-2019-8622 CVE-2019-8623
Affected Products:
  • SUSE Linux Enterprise Workstation Extension 12-SP4
  • SUSE Linux Enterprise Software Development Kit 12-SP4
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP4

An update that fixes 20 vulnerabilities is now available.

Description:

This update for webkit2gtk3 to version 2.24.2 fixes the following issues:
Security issues fixed:

  • CVE-2019-6237, CVE-2019-8571, CVE-2019-8583, CVE-2019-8584, CVE-2019-8586, CVE-2019-8587, CVE-2019-8594, CVE-2019-8595, CVE-2019-8596, CVE-2019-8597, CVE-2019-8601, CVE-2019-8607, CVE-2019-8608, CVE-2019-8609, CVE-2019-8610, CVE-2019-8615, CVE-2019-8611, CVE-2019-8619, CVE-2019-8622, CVE-2019-8623 (bsc#1135715).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Workstation Extension 12-SP4:
    zypper in -t patch SUSE-SLE-WE-12-SP4-2019-1850=1
  • SUSE Linux Enterprise Software Development Kit 12-SP4:
    zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1850=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1850=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-1850=1

Package List:

  • SUSE Linux Enterprise Workstation Extension 12-SP4 (noarch):
    • libwebkit2gtk3-lang-2.24.2-2.44.1
  • SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le s390x x86_64):
    • typelib-1_0-WebKit2WebExtension-4_0-2.24.2-2.44.1
    • webkit2gtk3-debugsource-2.24.2-2.44.1
    • webkit2gtk3-devel-2.24.2-2.44.1
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libjavascriptcoregtk-4_0-18-2.24.2-2.44.1
    • libjavascriptcoregtk-4_0-18-debuginfo-2.24.2-2.44.1
    • libwebkit2gtk-4_0-37-2.24.2-2.44.1
    • libwebkit2gtk-4_0-37-debuginfo-2.24.2-2.44.1
    • typelib-1_0-JavaScriptCore-4_0-2.24.2-2.44.1
    • typelib-1_0-WebKit2-4_0-2.24.2-2.44.1
    • webkit2gtk-4_0-injected-bundles-2.24.2-2.44.1
    • webkit2gtk-4_0-injected-bundles-debuginfo-2.24.2-2.44.1
    • webkit2gtk3-debugsource-2.24.2-2.44.1
  • SUSE Linux Enterprise Desktop 12-SP4 (x86_64):
    • libjavascriptcoregtk-4_0-18-2.24.2-2.44.1
    • libjavascriptcoregtk-4_0-18-debuginfo-2.24.2-2.44.1
    • libwebkit2gtk-4_0-37-2.24.2-2.44.1
    • libwebkit2gtk-4_0-37-debuginfo-2.24.2-2.44.1
    • typelib-1_0-JavaScriptCore-4_0-2.24.2-2.44.1
    • typelib-1_0-WebKit2-4_0-2.24.2-2.44.1
    • webkit2gtk-4_0-injected-bundles-2.24.2-2.44.1
    • webkit2gtk-4_0-injected-bundles-debuginfo-2.24.2-2.44.1
    • webkit2gtk3-debugsource-2.24.2-2.44.1
  • SUSE Linux Enterprise Desktop 12-SP4 (noarch):
    • libwebkit2gtk3-lang-2.24.2-2.44.1

References: