Security update for OpenEXR

SUSE Security Update: Security update for OpenEXR
Announcement ID: SUSE-SU-2019:14134-1
Rating: moderate
References: #1040109 #1040112 #1040113 #1040115
Cross-References: CVE-2017-9111 CVE-2017-9112 CVE-2017-9113 CVE-2017-9115
Affected Products:
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that fixes four vulnerabilities is now available.

Description:

This update for OpenEXR fixes the following issues:
Security issues fixed:

  • CVE-2017-9111: Fixed an invalid write of size 8 in the storeSSE function in ImfOptimizedPixelReading.h (bsc#1040109).
  • CVE-2017-9113: Fixed an invalid write of size 1 in the bufferedReadPixels function in ImfInputFile.cpp (bsc#1040113).
  • CVE-2017-9115: Fixed an invalid write of size 2 in the = operator function inhalf.h (bsc#1040115).
  • CVE-2017-9112: Fixed invalid read of size 1 in the getBits function in ImfHuf.cpp. (This was already fixed by the previous update bug not referenced.) (bsc#1040112)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-OpenEXR-14134=1

Package List:

  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • OpenEXR-debuginfo-1.6.1-83.17.8.2
    • OpenEXR-debugsource-1.6.1-83.17.8.2
  • SUSE Linux Enterprise Debuginfo 11-SP4 (ppc64 s390x x86_64):
    • OpenEXR-debuginfo-32bit-1.6.1-83.17.8.2

References: