Security update for zeromq

SUSE Security Update: Security update for zeromq
Announcement ID: SUSE-SU-2019:14117-1
Rating: important
References: #1140255
Cross-References: CVE-2019-13132
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4-CLIENT-TOOLS
  • SUSE Linux Enterprise Server 11-SP3-CLIENT-TOOLS

An update that fixes one vulnerability is now available.

Description:

This update for zeromq fixes the following issues:

  • CVE-2019-13132: An unauthenticated remote attacker could have exploited a stack overflow vulnerability on a server that is supposed to be protected by encryption and authentication to potentially gain a remote code execution. (bsc#1140255)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4-CLIENT-TOOLS:
    zypper in -t patch slesctsp4-zeromq-14117=1
  • SUSE Linux Enterprise Server 11-SP3-CLIENT-TOOLS:
    zypper in -t patch slesctsp3-zeromq-14117=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4-CLIENT-TOOLS (i586 ia64 ppc64 s390x x86_64):
    • libzmq3-4.0.4-3.3.1
  • SUSE Linux Enterprise Server 11-SP3-CLIENT-TOOLS (i586 ia64 ppc64 s390x x86_64):
    • libzmq3-4.0.4-3.3.1

References: