Security update for unzip

SUSE Security Update: Security update for unzip
Announcement ID: SUSE-SU-2019:0707-1
Rating: moderate
References: #1110194
Cross-References: CVE-2018-18384
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes one vulnerability is now available.

Description:

This update for unzip fixes the following issues:

  • CVE-2018-18384: Fixed a buffer overflow when listing archives (bsc#1110194)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-707=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-707=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • unzip-debuginfo-6.00-4.8.13
    • unzip-debugsource-6.00-4.8.13
    • unzip-doc-6.00-4.8.13
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • unzip-6.00-4.8.13
    • unzip-debuginfo-6.00-4.8.13
    • unzip-debugsource-6.00-4.8.13

References: