Security update for openssh

SUSE Security Update: Security update for openssh
Announcement ID: SUSE-SU-2019:0496-1
Rating: moderate
References: #1121816 #1121821 #1125687
Cross-References: CVE-2019-6109 CVE-2019-6111
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Desktop Applications 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that solves two vulnerabilities and has one errata is now available.

Description:

This update for openssh fixes the following issues:
Security vulnerabilities addressed:

  • CVE-2019-6109: Fixed an character encoding issue in the progress display of the scp client that could be used to manipulate client output, allowing for spoofing during file transfers (bsc#1121816)
  • CVE-2019-6111: Properly validate object names received by the scp client to prevent arbitrary file overwrites when interacting with a malicious SSH server (bsc#1121821)

Other bug fixes and changes:
  • Handle brace expansion in scp when checking that filenames sent by the server side match what the client requested (bsc#1125687)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-2019-496=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-496=1
  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-496=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-496=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15 (aarch64 ppc64le s390x x86_64):
    • openssh-debuginfo-7.6p1-9.23.1
    • openssh-debugsource-7.6p1-9.23.1
    • openssh-fips-7.6p1-9.23.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • openssh-cavs-7.6p1-9.23.1
    • openssh-cavs-debuginfo-7.6p1-9.23.1
    • openssh-debuginfo-7.6p1-9.23.1
    • openssh-debugsource-7.6p1-9.23.1
  • SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    • openssh-askpass-gnome-7.6p1-9.23.1
    • openssh-askpass-gnome-debuginfo-7.6p1-9.23.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • openssh-7.6p1-9.23.1
    • openssh-debuginfo-7.6p1-9.23.1
    • openssh-debugsource-7.6p1-9.23.1
    • openssh-helpers-7.6p1-9.23.1
    • openssh-helpers-debuginfo-7.6p1-9.23.1

References: