Security update for qemu

SUSE Security Update: Security update for qemu
Announcement ID: SUSE-SU-2019:0457-1
Rating: important
References: #1116717 #1117275 #1123156
Cross-References: CVE-2018-19364 CVE-2018-19489 CVE-2019-6778
Affected Products:
  • SUSE Linux Enterprise Server 12-LTSS

An update that fixes three vulnerabilities is now available.

Description:

This update for qemu fixes the following issues:
Security issues fixed:

  • CVE-2019-6778: Fixed a heap buffer overflow issue in the SLiRP networking implementation (bsc#1123156).
  • CVE-2018-19489: Fixed a denial of service vulnerability in virtfs (bsc#1117275).
  • CVE-2018-19364: Fixed a use-after-free if the virtfs interface resulting in a denial of service (bsc#1116717).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-2019-457=1

Package List:

  • SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):
    • qemu-2.0.2-48.49.3
    • qemu-block-curl-2.0.2-48.49.3
    • qemu-block-curl-debuginfo-2.0.2-48.49.3
    • qemu-debugsource-2.0.2-48.49.3
    • qemu-guest-agent-2.0.2-48.49.3
    • qemu-guest-agent-debuginfo-2.0.2-48.49.3
    • qemu-lang-2.0.2-48.49.3
    • qemu-tools-2.0.2-48.49.3
    • qemu-tools-debuginfo-2.0.2-48.49.3
  • SUSE Linux Enterprise Server 12-LTSS (s390x x86_64):
    • qemu-kvm-2.0.2-48.49.3
  • SUSE Linux Enterprise Server 12-LTSS (ppc64le):
    • qemu-ppc-2.0.2-48.49.3
    • qemu-ppc-debuginfo-2.0.2-48.49.3
  • SUSE Linux Enterprise Server 12-LTSS (noarch):
    • qemu-ipxe-1.0.0-48.49.3
    • qemu-seabios-1.7.4-48.49.3
    • qemu-sgabios-8-48.49.3
    • qemu-vgabios-1.7.4-48.49.3
  • SUSE Linux Enterprise Server 12-LTSS (x86_64):
    • qemu-block-rbd-2.0.2-48.49.3
    • qemu-block-rbd-debuginfo-2.0.2-48.49.3
    • qemu-x86-2.0.2-48.49.3
    • qemu-x86-debuginfo-2.0.2-48.49.3
  • SUSE Linux Enterprise Server 12-LTSS (s390x):
    • qemu-s390-2.0.2-48.49.3
    • qemu-s390-debuginfo-2.0.2-48.49.3

References: