Security update for haproxy

SUSE Security Update: Security update for haproxy
Announcement ID: SUSE-SU-2019:0061-1
Rating: important
References: #1119368 #1119419
Cross-References: CVE-2018-20102 CVE-2018-20103
Affected Products:
  • SUSE Linux Enterprise High Availability 15

An update that fixes two vulnerabilities is now available.

Description:

This update for haproxy to version 1.8.15 fixes the following issues:
Security issues fixed:

  • CVE-2018-20102: Fixed an out-of-bounds read in dns_validate_dns_response(), which allowed for memory disclosure (bsc#1119368)
  • CVE-2018-20103: Fixed an infinite recursion via crafted packet allows stack exhaustion and denial of service (bsc#1119419)

Other notable bug fixes:
  • Fix off-by-one write in dns_validate_dns_response()
  • Fix out-of-bounds read via signedness error in dns_validate_dns_response()
  • Prevent out-of-bounds read in dns_validate_dns_response()
  • Prevent out-of-bounds read in dns_read_name()
  • Prevent stack-exhaustion via recursion loop in dns_read_name

For a full list of changes, please refer to: https://www.haproxy.org/download/1.8/src/CHANGELOG

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 15:
    zypper in -t patch SUSE-SLE-Product-HA-15-2019-61=1

Package List:

  • SUSE Linux Enterprise High Availability 15 (aarch64 ppc64le s390x x86_64):
    • haproxy-1.8.15~git0.6b6a350a-3.6.2
    • haproxy-debuginfo-1.8.15~git0.6b6a350a-3.6.2
    • haproxy-debugsource-1.8.15~git0.6b6a350a-3.6.2

References: