Recommended update for libsodium

SUSE Recommended Update: Recommended update for libsodium
Announcement ID: SUSE-RU-2019:3400-1
Rating: moderate
References: #1146257
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has one recommended fix can now be installed.

Description:

This update for libsodium fixes the following issues:

  • build libsodium23-32bit, which is required by zeromq's -32bit packages. (bsc#1146257)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-3400=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-3400=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libsodium-debugsource-1.0.16-4.3.18
    • libsodium-devel-1.0.16-4.3.18
    • libsodium23-1.0.16-4.3.18
    • libsodium23-debuginfo-1.0.16-4.3.18
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (x86_64):
    • libsodium23-32bit-1.0.16-4.3.18
    • libsodium23-32bit-debuginfo-1.0.16-4.3.18
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libsodium-debugsource-1.0.16-4.3.18
    • libsodium-devel-1.0.16-4.3.18
    • libsodium23-1.0.16-4.3.18
    • libsodium23-debuginfo-1.0.16-4.3.18
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • libsodium23-32bit-1.0.16-4.3.18
    • libsodium23-32bit-debuginfo-1.0.16-4.3.18

References: