Recommended update for python-kiwi

SUSE Recommended Update: Recommended update for python-kiwi
Announcement ID: SUSE-RU-2019:3314-1
Rating: moderate
References: #1112357 #1124885 #1127173 #1129566 #1132455 #1136444 #1142899 #1143033 #1149686 #1150190 #1155285
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Development Tools 15

An update that has 11 recommended fixes can now be installed.

Description:

This update for python-kiwi fixes the following issues:

  • Update SLE15-GA to align with SLE15-SP1. (bsc#1155285)
  • Fix rpmdb compat link setup. (bsc#1150190)
  • Add '--add-bootstrap-packages' option allowing to specify additional packages. (bsc#1149686)
  • Avoid default installation of dracut kiwi modules in the initrd. (bsc#1142899, bsc#1136444)
  • Add support for custom fstab script extension. (bsc#1129566)
  • Add crypt dependency to kiwi-lib dracut modulehe kiwi-lib dracut module to include crypt module. (bsc#1142899)
  • Install rmdir according to requirements of dracut. (bsc#1143033)
  • Avoid not to crash on missing 'HOME' directory. (bsc#1149686)
  • Extend spare partition setup. (bsc#1129566)
  • Preserve licenses and other text files by 'baseStripFirmware'. (bsc#1132455)
  • Delete firmware 'check_grub_efi_installed_for_efi_firmware' to prevent checking static list during runtime check. (bsc#1149686)
  • In addition to the support for fstab.append, users can provide a patch file to change the contents of the fstab file. (bsc#1129566)
  • Change the output format of the bundler shasum file to be compatible with a 'sha256sum --check' call. (bsc#1127173)
  • Fixed import of signing keys make accessible for zypper. (bsc#1112357)
  • Fix location of grub unicode font. (bsc#1124885)
  • Handle location of the rpm DB on the macro level. (bsc#1112357)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-3314=1
  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2019-3314=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • python-kiwi-debugsource-9.18.16-3.24.1
  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • dracut-kiwi-lib-9.18.16-3.24.1
    • dracut-kiwi-live-9.18.16-3.24.1
    • dracut-kiwi-oem-dump-9.18.16-3.24.1
    • dracut-kiwi-oem-repart-9.18.16-3.24.1
    • dracut-kiwi-overlay-9.18.16-3.24.1
    • kiwi-man-pages-9.18.16-3.24.1
    • kiwi-tools-9.18.16-3.24.1
    • kiwi-tools-debuginfo-9.18.16-3.24.1
    • python-kiwi-debugsource-9.18.16-3.24.1
    • python3-kiwi-9.18.16-3.24.1
  • SUSE Linux Enterprise Module for Development Tools 15 (x86_64):
    • kiwi-pxeboot-9.18.16-3.24.1

References: