Recommended update for drbd-utils

SUSE Recommended Update: Recommended update for drbd-utils
Announcement ID: SUSE-RU-2019:2631-1
Rating: moderate
References: #1037109 #1064402 #1115606 #1145296
Affected Products:
  • SUSE Linux Enterprise High Availability 15

An update that has four recommended fixes can now be installed.

Description:

This update for drbd-utils contains the following fixes:

  • Fix the wrong return code with cib_apply_diff. (bsc#1145296)

  • Update to new upstream release 9.6.0. (bsc#1115606) * usage-count: also count notty users if possible. * drbd-overview: remove it, we have drbdtop/drbdmon. saves all the Perl deps. * drbdmon: update frequency limiting, debug log for drbdevents, use altbuffer,... * drbdsetup show: on 9 allow json output. mainly used in our CI, don't expect a stable field names yet. * drbdsetup status: on 9 fix json output to not include NaN/Infinity * allow higher resync rates: first customers hit a limit. this requires an updated kernel module as well (e.g., 9.0.16) * init: fix some 8-only leftovers (sh-b-pri), sanitize the retry logic * doc: document various 9 features that got forgotten (e.g., quorum-lost) * build: various small fixes that popped up while playing with meson

  • Update to 9.5.0 * drbdmon: allow to start in problems view (--problems) * drbdadm,v9: fix always failing stacked handlers from kernel * drbdadm,v9: adjust now hands over the information that a diskfull->diskless change was intentional. * drbdadm,v9: adjust verifies now IPs

  • Update to 9.4.0 * drbdmeta: don't exit with negative return codes * usage counts: only register if we know driver version * drbdsetup,v9: expose detailed verify/resync statistics * drbdsetup,v9,json: saner types for client/peer-client/quorum on --json * drbdsetup,v9: expose client/peer-client in status if !isatty()
  • Including fix for SLE12SP3: * Remove hardcoded local5 of logfacility. (bsc#1064402) * drbdmeta does not propagate full bitmap. (bsc#1037109)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 15:
    zypper in -t patch SUSE-SLE-Product-HA-15-2019-2631=1

Package List:

  • SUSE Linux Enterprise High Availability 15 (aarch64 ppc64le s390x x86_64):
    • drbd-utils-9.6.0-3.6.1
    • drbd-utils-debuginfo-9.6.0-3.6.1
    • drbd-utils-debugsource-9.6.0-3.6.1

References: