Recommended update for SUSE Manager Proxy 3.2

SUSE Recommended Update: Recommended update for SUSE Manager Proxy 3.2
Announcement ID: SUSE-RU-2019:2521-1
Rating: moderate
References: #1093381 #1138454 #1142774 #1143016 #1143562 #1144889 #1145086 #1146419 #1146869
Affected Products:
  • SUSE Manager Proxy 3.2

An update that has 9 recommended fixes can now be installed.

Description:


This update fixes the following issues:
spacewalk-backend:

  • Remove credentials also from potential rhn.conf backup files in spacewalk-debug (bsc#1146419)
  • Do not make 'rhn-satellite-exporter' to crash with "AttributeError" (bsc#1146869)
  • Spacewalk-remove-channel check that channel doesn't have cloned channels before deleting it (bsc#1138454)
  • Prevent duplicate changelog entries due VARCHAR(3000) db text column (bsc#1144889)
  • Avoid traceback on mgr-inter-sync when exception message contains UTF8 characters or there are problems with the package cache (bsc#1143016) registered guest (bsc#1093381)

spacewalk-client-tools:
  • Invalidate cache 5 minutes before actual expiration(bsc#1143562)

spacewalk-web:
  • Fix the 'include recommended' button on channels selection in SSM (bsc#1145086)
  • Normalize date formats for actions, notifications and clm (bsc#1142774)
  • Add unsupported browser warning when using Internet Explorer

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Manager Proxy 3.2:
    zypper in -t patch SUSE-SUSE-Manager-Proxy-3.2-2019-2521=1

Package List:

  • SUSE Manager Proxy 3.2 (noarch):
    • python2-spacewalk-check-2.8.22.5-3.6.1
    • python2-spacewalk-client-setup-2.8.22.5-3.6.1
    • python2-spacewalk-client-tools-2.8.22.5-3.6.1
    • spacewalk-backend-2.8.57.19-3.39.2
    • spacewalk-backend-libs-2.8.57.19-3.39.2
    • spacewalk-base-minimal-2.8.7.19-3.36.1
    • spacewalk-base-minimal-config-2.8.7.19-3.36.1
    • spacewalk-check-2.8.22.5-3.6.1
    • spacewalk-client-setup-2.8.22.5-3.6.1
    • spacewalk-client-tools-2.8.22.5-3.6.1
    • susemanager-web-libs-2.8.7.19-3.36.1

References: