Recommended update for cloud-init

SUSE Recommended Update: Recommended update for cloud-init
Announcement ID: SUSE-RU-2019:2354-1
Rating: important
References: #1136440 #1141969 #1144363 #1144881
Affected Products:
  • SUSE Linux Enterprise Module for Public Cloud 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15

An update that has four recommended fixes can now be installed.

Description:

This update for cloud-init fixes the following issues:

  • Properly handle static routes. The EphemeralDHCP context manager did not parse or handle rfc3442 classless static routes which prevented reading datasource metadata in some clouds (bsc#1141969)
  • Fixes an issue where udevadm settle was executed incorrectly (bsc#1144363)
  • If no routes are set for a subnet but the subnet has a gateway specified, set the gateway as the default route for the interface (bsc#1144881)
  • Fixes an issue where the OpenStack data source could not be detected on VMWare Integrated OpenStack (VIO). This has resulted in an unconfigured instance (bsc#1136440)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Public Cloud 15:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-2019-2354=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2354=1

Package List:

  • SUSE Linux Enterprise Module for Public Cloud 15 (aarch64 ppc64le s390x x86_64):
    • cloud-init-19.1-5.11.1
    • cloud-init-config-suse-19.1-5.11.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • cloud-init-doc-19.1-5.11.1

References: