Recommended update for mvapich2

SUSE Recommended Update: Recommended update for mvapich2
Announcement ID: SUSE-RU-2019:1501-1
Rating: moderate
References: #1116458 #1129421 #1133797
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP4
  • SUSE Linux Enterprise Server 12-SP4

An update that has three recommended fixes can now be installed.

Description:

This update for mvapich2 provides the following fixes:

  • Fix a segfault when running on a machine with no RDMA hardware. (bsc#1133797)
  • Add patch to remove obsolete GCC check and also patch autogen.sh to get the autotools working in SLE12SP4. (bsc#1129421)
  • Force to re-run autotools to generate properly the files after patching files.
  • Add macro _hpc_mvapich2_modules for modules support (bsc#1116458).

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 12-SP4:
    zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-1501=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1501=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le s390x x86_64):
    • mvapich2-debuginfo-2.2-10.3.1
    • mvapich2-debugsource-2.2-10.3.1
    • mvapich2-devel-2.2-10.3.1
    • mvapich2-devel-static-2.2-10.3.1
  • SUSE Linux Enterprise Software Development Kit 12-SP4 (x86_64):
    • mvapich2-psm-debuginfo-2.2-10.3.1
    • mvapich2-psm-debugsource-2.2-10.3.1
    • mvapich2-psm-devel-2.2-10.3.1
    • mvapich2-psm-devel-static-2.2-10.3.1
    • mvapich2-psm2-debuginfo-2.2-10.3.1
    • mvapich2-psm2-debugsource-2.2-10.3.1
    • mvapich2-psm2-devel-2.2-10.3.1
    • mvapich2-psm2-devel-static-2.2-10.3.1
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • mvapich2-2.2-10.3.1
    • mvapich2-debuginfo-2.2-10.3.1
    • mvapich2-debugsource-2.2-10.3.1
  • SUSE Linux Enterprise Server 12-SP4 (x86_64):
    • mvapich2-psm-2.2-10.3.1
    • mvapich2-psm-debuginfo-2.2-10.3.1
    • mvapich2-psm-debugsource-2.2-10.3.1
    • mvapich2-psm2-2.2-10.3.1
    • mvapich2-psm2-debuginfo-2.2-10.3.1
    • mvapich2-psm2-debugsource-2.2-10.3.1

References: