Recommended update for yast2-storage-ng, libstorage-ng, and autoyast2

SUSE Recommended Update: Recommended update for yast2-storage-ng, libstorage-ng, and autoyast2
Announcement ID: SUSE-RU-2019:1498-1
Rating: moderate
References: #1104899 #1120979 #1121720 #1122660 #1130256 #1134330
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15
  • SUSE Linux Enterprise Installer 15

An update that has 6 recommended fixes can now be installed.

Description:

This update for libstorage-ng, yast2-storage-ng, and autoyast2 fixes the following issues:
# Package: yast2-storage-ng

  • Fixes broken support for retaining existing MD RAIDs in some scenarios (bsc#1120979, bsc#1121720).
  • Adds support for installing over NFS (bsc#1130256).
  • Adds a new format for importing/exporting NFS drives
  • It will no longer ask for a reusable filesystem when it's not really needed (bsc#1134330)

# Package: libstorage-ng
  • Does no longer crash when parsing docker devices (bsc#1104899)

# Package: autoyast2
  • Removed check for available devices. When there are no devices, the proposal issues will be shown (bsc#1130256)
  • Fixes an issue where IPv6 gets activated even if it was deactivated (bsc#1122660)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-1498=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1498=1
  • SUSE Linux Enterprise Installer 15:
    zypper in -t patch SUSE-SLE-INSTALLER-15-2019-1498=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-debuginfo-3.3.318-3.25.5
    • libstorage-ng-debugsource-3.3.318-3.25.5
    • libstorage-ng-integration-tests-3.3.318-3.25.5
    • libstorage-ng-python3-3.3.318-3.25.5
    • libstorage-ng-python3-debuginfo-3.3.318-3.25.5
    • libstorage-ng-utils-3.3.318-3.25.5
    • libstorage-ng-utils-debuginfo-3.3.318-3.25.5
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-debuginfo-3.3.318-3.25.5
    • libstorage-ng-debugsource-3.3.318-3.25.5
    • libstorage-ng-devel-3.3.318-3.25.5
    • libstorage-ng-ruby-3.3.318-3.25.5
    • libstorage-ng-ruby-debuginfo-3.3.318-3.25.5
    • libstorage-ng1-3.3.318-3.25.5
    • libstorage-ng1-debuginfo-3.3.318-3.25.5
    • yast2-storage-ng-4.0.221-3.43.1
  • SUSE Linux Enterprise Module for Basesystem 15 (noarch):
    • autoyast2-4.0.69-3.17.10
    • autoyast2-installation-4.0.69-3.17.10
    • libstorage-ng-lang-3.3.318-3.25.5
  • SUSE Linux Enterprise Installer 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-ruby-3.3.318-3.25.5
    • libstorage-ng1-3.3.318-3.25.5
    • yast2-storage-ng-4.0.221-3.43.1
  • SUSE Linux Enterprise Installer 15 (noarch):
    • autoyast2-4.0.69-3.17.10
    • autoyast2-installation-4.0.69-3.17.10
    • libstorage-ng-lang-3.3.318-3.25.5

References: