Recommended update for arpwatch

SUSE Recommended Update: Recommended update for arpwatch
Announcement ID: SUSE-RU-2019:13980-1
Rating: moderate
References: #1119851
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11-SP4
  • SUSE Linux Enterprise Server 11-SP4
  • SUSE Linux Enterprise Point of Sale 11-SP3
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that has one recommended fix can now be installed.

Description:

This update for arpwatch provides the following fix:

  • Prevent a memory leak in gethname. (bsc#1119851)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 11-SP4:
    zypper in -t patch sdksp4-arpwatch-13980=1
  • SUSE Linux Enterprise Server 11-SP4:
    zypper in -t patch slessp4-arpwatch-13980=1
  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-arpwatch-13980=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-arpwatch-13980=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ia64 ppc64 s390x x86_64):
    • arpwatch-ethercodes-build-2.1a15-131.23.2.3.1
  • SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):
    • arpwatch-2.1a15-131.23.2.3.1
  • SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
    • arpwatch-2.1a15-131.23.2.3.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ia64 ppc64 s390x x86_64):
    • arpwatch-debuginfo-2.1a15-131.23.2.3.1
    • arpwatch-debugsource-2.1a15-131.23.2.3.1

References: