Recommended update for openCryptoki

SUSE Recommended Update: Recommended update for openCryptoki
Announcement ID: SUSE-RU-2019:13967-1
Rating: low
References: #1007081 #1122340
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11-SP4
  • SUSE Linux Enterprise Server 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that has two recommended fixes can now be installed.

Description:

This update for openCryptoki provides the following fixes:

  • Removed reference to pkcs1_startup from pkcsslotd. (bsc#1007081)
  • Make ICA token mechanism list initialization thread safe. (bsc#1122340)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 11-SP4:
    zypper in -t patch sdksp4-openCryptoki-13967=1
  • SUSE Linux Enterprise Server 11-SP4:
    zypper in -t patch slessp4-openCryptoki-13967=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-openCryptoki-13967=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 ppc64 s390x x86_64):
    • openCryptoki-devel-3.2-0.22.5.1
  • SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 x86_64):
    • openCryptoki-3.2-0.22.5.1
  • SUSE Linux Enterprise Server 11-SP4 (i586 ppc64 s390 s390x x86_64):
    • openCryptoki-3.2-0.22.5.1
  • SUSE Linux Enterprise Server 11-SP4 (ppc64 s390x x86_64):
    • openCryptoki-64bit-3.2-0.22.5.1
  • SUSE Linux Enterprise Server 11-SP4 (i586 s390):
    • openCryptoki-32bit-3.2-0.22.5.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • openCryptoki-debuginfo-3.2-0.22.5.1
    • openCryptoki-debugsource-3.2-0.22.5.1

References: