Recommended update for supportutils

SUSE Recommended Update: Recommended update for supportutils
Announcement ID: SUSE-RU-2019:1384-1
Rating: important
References: #1081326 #1088234 #1100529 #1120967 #1132865 #1133723 #1134599
Affected Products:
  • SUSE OpenStack Cloud 7
  • SUSE Linux Enterprise Server for SAP 12-SP2
  • SUSE Linux Enterprise Server for SAP 12-SP1
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Server 12-SP3
  • SUSE Linux Enterprise Server 12-SP2-LTSS
  • SUSE Linux Enterprise Server 12-SP1-LTSS
  • SUSE Linux Enterprise Server 12-LTSS
  • SUSE Linux Enterprise Desktop 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP3
  • SUSE Enterprise Storage 4
  • SUSE CaaS Platform ALL

An update that has 7 recommended fixes can now be installed.

Description:

This update for supportutils fixes the following issues:
* SUSE specific infrastructure is now used (bsc#1132865) * Uploads now use https by default (bsc#1134599) * Support for FTPS has been added * Files in the tarball now have 660 permissions instead of 600 * The supportconfig.conf man pages have been updated to add some missing paramaters and fix some incorrect information (bsc#1088234) * Fix issues where some customers were unable to collect logs due to commands not timing out (bsc#1100529) (bsc#1120967) * DRBD resource configs were missing in support config (bsc#1133723) * FTPES now uses the --ssl-reqd paramater instead of the depricated --ftp-ssl * sapconf and log were missing from tuned.txt (bsc#1081326) * Some deprecated chkconfig code has been removed

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud 7:
    zypper in -t patch SUSE-OpenStack-Cloud-7-2019-1384=1
  • SUSE Linux Enterprise Server for SAP 12-SP2:
    zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-1384=1
  • SUSE Linux Enterprise Server for SAP 12-SP1:
    zypper in -t patch SUSE-SLE-SAP-12-SP1-2019-1384=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1384=1
  • SUSE Linux Enterprise Server 12-SP3:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2019-1384=1
  • SUSE Linux Enterprise Server 12-SP2-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-2019-1384=1
  • SUSE Linux Enterprise Server 12-SP1-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP1-2019-1384=1
  • SUSE Linux Enterprise Server 12-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-2019-1384=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-1384=1
  • SUSE Linux Enterprise Desktop 12-SP3:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2019-1384=1
  • SUSE Enterprise Storage 4:
    zypper in -t patch SUSE-Storage-4-2019-1384=1
  • SUSE CaaS Platform ALL:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE OpenStack Cloud 7 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server for SAP 12-SP2 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server for SAP 12-SP1 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server 12-SP3 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server 12-SP1-LTSS (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Server 12-LTSS (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Desktop 12-SP4 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Linux Enterprise Desktop 12-SP3 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE Enterprise Storage 4 (noarch):
    • supportutils-3.0.2-95.24.1
  • SUSE CaaS Platform ALL (noarch):
    • supportutils-3.0.2-95.24.1

References: