Recommended update for rubygem-crowbar-client

SUSE Recommended Update: Recommended update for rubygem-crowbar-client
Announcement ID: SUSE-RU-2019:1197-1
Rating: moderate
References: #1118004
Affected Products:
  • SUSE OpenStack Cloud Crowbar 8

An update that has one recommended fix can now be installed.

Description:

This update for rubygem-crowbar-client fixes the following issues:

  • Update to 3.9.0 - Add support for the restricted APIs - Add --raw to "proposal show" & "proposal edit" - Correctly parse error messages that we don't handle natively - Better upgrade repocheck output

  • Update to 3.7.0 - upgrade: Use cloud_version config for upgrade - ses: Add ses upload subcommand - Add cloud_version config field. - Wrap os-release file parsing for better reuse. - upgrade: Fix repocheck component in error message - upgrade: Better repocheck output

  • updated to version 3.6.1 see installed CHANGELOG.md ## [3.6.1](https://github.com/crowbar/crowbar-client/releases/tag/v3.6.1) - 2018-12-07

* BUGFIX * Hide the database step when it is not used (bsc#1118004) * ENHANCEMENT * Fix help strings * Describe how to upgrade more nodes with one command

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-1197=1

Package List:

  • SUSE OpenStack Cloud Crowbar 8 (x86_64):
    • ruby2.1-rubygem-crowbar-client-3.9.0-3.6.1

References: