Recommended update for sg3_utils

SUSE Recommended Update: Recommended update for sg3_utils
Announcement ID: SUSE-RU-2019:1160-1
Rating: moderate
References: #1005063 #1069384 #1131482 #1133418 #840054
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has 5 recommended fixes can now be installed.

Description:

This update for sg3_utils fixes the following issues:

  • Update to version 1.44~763+19.1ed0757: * rescan-scsi-bus.sh: use LUN wildcard in idlist (bsc#1069384) * 40-usb-blacklist.rules: use ID_SCSI_INQUIRY (bsc#840054, bsc#1131482) * Changed versioning scheme (svn r763, pre-release of upstream 1.44, plus 16 SUSE patches, SUSE git commit b2fedfa) * 59-fc-wwpn-id.rules: fix rule syntax (bsc#1133418)
  • Spec file: add fc_wwpn_id to generate by-path links for fibrechannel (bsc#1005063)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1160=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libsgutils-devel-1.44~763+19.1ed0757-9.3.1
    • libsgutils2-1_43-2-1.44~763+19.1ed0757-9.3.1
    • libsgutils2-1_43-2-debuginfo-1.44~763+19.1ed0757-9.3.1
    • sg3_utils-1.44~763+19.1ed0757-9.3.1
    • sg3_utils-debuginfo-1.44~763+19.1ed0757-9.3.1
    • sg3_utils-debugsource-1.44~763+19.1ed0757-9.3.1

References: