Recommended update for SUSE Manager Client Tools

SUSE Recommended Update: Recommended update for SUSE Manager Client Tools
Announcement ID: SUSE-RU-2019:0883-1
Rating: moderate
References: #1095804 #1103388 #1103696 #1104034 #1120242 #1125610 #1127488 #1128529 #1128564 #1129243 #1129300 #987798
Affected Products:
  • SUSE Manager Tools 15-BETA

An update that has 12 recommended fixes can now be installed.

Description:


This update fixes the following issues:
hwdata:

  • Fix build for older distributon not supporting license tag at the SPEC file

rhnlib:
  • Version 4.0.6-1
  • Add group to python*-rhnlib to fix building at SLE11
  • Version 4.0.5-1
  • Read SSL decoded buffer completely when no pending bytes on the underlying connection.
  • Version 4.0.4-1
  • Fix encoding issues after porting to Python 3.
  • Version 4.0.3-1
  • Sync changes from Spacewalk
  • 1652859 - python3 http.client does not contain _set_hostport()
  • Version 4.0.2-1
  • Use rpm for debian packaging
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

spacecmd:
  • Version 4.0.9-1
  • Add Pylint setup
  • Replace iteritems with items for python2/3 compat (bsc#1129243)
  • Version 4.0.8-1
  • Fix python 3 bytes issue when handling config channels
  • Version 4.0.7-1
  • Version 4.0.6-1
  • Prevent spacecmd crashing when piping the output in Python 3 (bsc#1125610)
  • Version 4.0.5-1
  • Fix compatibility with Python 3
  • Version 4.0.4-1
  • Version 4.0.3-1
  • Add function to merge errata and packages through spacecmd (bsc#987798)
  • Version 4.0.2-1
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

spacewalk-backend:
  • Version 4.0.12-1
  • Include arch to distinct latest packages on reposync.
  • Migrate missing spacewalk-cfg-get script to Python3
  • Improve dependency solving algorithm for spacewalk-repo-sync.
  • Version 4.0.11-1
  • Remove apache access_compat module and adapt config files
  • Add support for getting latest versions from RPM packages when running "spacewalk-repo-sync" after migration to Zypper.
  • Include packages dependencies on "spacewalk-repo-sync" when using filters for RPM packages.
  • Allow package filtering (name matching) on spacewalk-repo-sync after migrating away from yum.
  • Fix crash when importing new channel families on 'mgr-inter-sync' (bsc#1129300)
  • Make Zypper to use the spacewalk GPG keyring in reposync (bsc#1128529)
  • Fix: handle non-standard filenames for comps.xml (bsc#1120242)
  • Avoid DB constraint violations caused by extended UTF8 characters on the RPM headers
  • Prevent mgr-inter-sync crash because 'SuseProductRepository' not found (bsc#1129300)
  • Fix invalid mode error when doing spacewalk-repo-sync on Ubuntu official repos.
  • Version 4.0.10-1
  • Make sure the package download url does not have '//' (bsc#1127488)
  • Fix bootstrapping SLE15 traditional client (bsc#1128564)
  • Version 4.0.9-1
  • Fix reading LOB objects with python3
  • Version 4.0.8-1
  • Fix "mgr-inter-sync" problems after Python 3 migration.
  • Mgr-sign-metadata can optionally clear-sign metadata files
  • Version 4.0.7-1
  • Allow errata import from local repositories.
  • Fix "rhnpush" after migration to Python 3.
  • Fix package import issues when package encoding is ISO8859-1.
  • Fix issues with HTTP proxy and reposync.
  • Solve Python 3 problem and allow traditional registration.
  • Version 4.0.6-1
  • Add "python-urlgrabber" as a new dependency.
  • Fix Python3 issues on satellite_tools scripts
  • Version 4.0.5-1
  • Use "Zypper" and "libsolv" in "spacewalk-repo-sync". Replace "yum".
  • Require the correct dependency for python-rpm to allow the Proxy to work with Python3 only
  • Make rhn-ssl-dbstore compatible with python3
  • Version 4.0.4-1
  • Take only text files from /srv/salt to make spacewalk-debug smaller (bsc#1103388)
  • Version 4.0.3-1
  • Version 4.0.2-1
  • Support mirroring of source packages
  • Make spacewalk-backend code compatible with Python 3
  • Prepare spacewalk-backend packages to build on Python 3
  • Replace PyPAM with python-python-pam
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)
  • Disable Oracle support for openSUSE (bsc#1095804)

spacewalk-client-tools:
  • Version 4.0.6-1
  • Fix bootstrapping SLE15 traditional client (bsc#1128564)
  • Version 4.0.5-1
  • Sync with Spacewalk
  • Add ability to work behind http proxies
  • 1666099 - python3 is picky about bytes and string
  • Version 4.0.4-1
  • Fix testConfig.py
  • Version 4.0.3-1
  • Version 4.0.2-1
  • Use rpm for debian packaging
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

spacewalk-koan:
  • Version 4.0.3-1
  • Port unit tests to python3
  • Version 4.0.2-1
  • Fix building on openSUSE 15.0
  • Add Uyuni URL to package
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

spacewalk-oscap:
  • Version 4.0.3-1
  • Fix python2 compilation on openSUSE
  • Version 4.0.2-1
  • Add Uyuni URL to package
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

spacewalk-remote-utils:
  • Version 4.0.3-1
  • Sync changes from Spacewalk
  • 1649374 - Update spacewalk-remote-utils with RHEL 7.6 channel definitions
  • 1633532 - Use python-gpg instead of python-gpgme where possible
  • Version 4.0.2-1
  • Add Uyuni URL to package
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

spacewalk-usix:
  • Version 4.0.7-1
  • Fix pylint issues.
  • Version 4.0.6-1
  • Add PyLint runner and configuration.
  • Version 4.0.5-1
  • Fix UnicodeType as bytes on Python 3
  • Version 4.0.4-1
  • Fix BufferType as bytes on Python 3
  • Version 4.0.3-1
  • Fix StringType as str on Python 3
  • Version 4.0.2-1
  • Use rpm for debian packaging
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

supportutils-plugin-susemanager-client:
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

suseRegisterInfo:
  • Version 4.0.2-1
  • Make suseRegisterInfo compatible with Python 2 and 3
  • Version 4.0.1-1
  • Bump version to 4.0.0 (bsc#1104034)
  • Fix copyright for the package specfile (bsc#1103696)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Manager Tools 15-BETA:
    zypper in -t patch SUSE-SLE-Manager-Tools-15-BETA-2019-883=1

Package List:

  • SUSE Manager Tools 15-BETA (noarch):
    • hwdata-0.314-6.3.2
    • koan-2.9.0-6.2.1
    • python3-hwdata-2.3.5-5.2.1
    • python3-rhnlib-4.0.6-5.3.2
    • python3-spacewalk-backend-libs-4.0.12-6.3.3
    • python3-spacewalk-check-4.0.6-6.3.2
    • python3-spacewalk-client-setup-4.0.6-6.3.2
    • python3-spacewalk-client-tools-4.0.6-6.3.2
    • python3-spacewalk-koan-4.0.3-5.3.2
    • python3-spacewalk-oscap-4.0.3-5.3.2
    • python3-spacewalk-usix-4.0.7-5.3.2
    • python3-suseRegisterInfo-4.0.2-5.3.2
    • python3-zypp-plugin-spacewalk-1.0.4-6.2.1
    • spacecmd-4.0.9-6.3.2
    • spacewalk-check-4.0.6-6.3.2
    • spacewalk-client-setup-4.0.6-6.3.2
    • spacewalk-client-tools-4.0.6-6.3.2
    • spacewalk-koan-4.0.3-5.3.2
    • spacewalk-oscap-4.0.3-5.3.2
    • spacewalk-remote-utils-4.0.3-6.3.2
    • supportutils-plugin-susemanager-client-4.0.1-5.3.2
    • suseRegisterInfo-4.0.2-5.3.2
    • zypp-plugin-spacewalk-1.0.4-6.2.1

References: