Recommended update for crowbar packages

SUSE Recommended Update: Recommended update for crowbar packages
Announcement ID: SUSE-RU-2019:0478-1
Rating: moderate
References: #1085170 #1103882 #1114851 #1116686 #1116853
Affected Products:
  • SUSE OpenStack Cloud 7
  • SUSE Enterprise Storage 4

An update that has 5 recommended fixes can now be installed.

Description:

This update for crowbar packages fixes the following issues:
crowbar:

  • upgrade: rabbitmq and epmd packages need to go in the right order

crowbar-core:
  • upgrade: Map jsonapi for respond_to
  • travis fix for bundler problems
  • upgrade: Increase delayed_job time limit
  • provisioner: validate format of additional ssh keys section
  • upgrade: Improve handling of zypper prompts (bsc#1116853)
  • upgrade: Allow upgrade with monasca agents on compute nodes
  • ohai: fix path to check for aacraid driver (bsc#1085170 bsc#1103882)
  • upgrade: Precheck for unsaved proposals
  • crowbar: move disallow chef restarts out of experimental
  • Removed experimental.yml because won't be necessary

crowbar-ha:
  • Update travis config to solve bundler dependency

crowbar-openstack:
  • mariadb: Set wsrep_sst_method to mariabackup (bsc#1116686)
  • Update travis config to solve bundler dependency
  • nova: Use internal glance and neutron endpoints
  • horizon: Fix SSL CA configuration for apache 2.4
  • cinder: Only set up SSL on API nodes
  • nova/neutron: Restart immediately on keystone changes
  • keystone: Fix update endpoint for ha (bsc#1114851)
  • keystone: Refactor keystone_register retry loop
  • keystone: Fix CA cert Apache config
  • database: Prevent deploying mysql-server role to monasca node
  • ssl: Fix ACL setup in ssl_setup provider
  • horizon: load monasca from databag
  • galera: Install system tables only on the founder node
  • galera: Use monitoring user for observing wsrep state
  • neutron: disable metering agent if no ceilometer
  • neutron: Fix "enable_metadata_proxy" setting for DVR setups
  • rabbitmq: Add list of tags comma separated for extra users
  • neutron/nova: allow overriding default_log_levels
  • neutron: disable metadata proxy when metadata is forced
  • Gemfile: Drop crowbar-validate-databags gem version
  • travis: tests databags
  • database: fix duplicated number migration
  • Fix migrations
  • rabbitmq: block client port on startup
  • rabbitmq: change ha-sync-mode to automatic
  • rabbitmq: disable mirroring for several queues
  • rabbitmq: allow disabling queue mirroring

crowbar-ui:
  • upgrade: Fix "Next" button behavior
  • upgrade: Add admin repochecks error title

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud 7:
    zypper in -t patch SUSE-OpenStack-Cloud-7-2019-478=1
  • SUSE Enterprise Storage 4:
    zypper in -t patch SUSE-Storage-4-2019-478=1

Package List:

  • SUSE OpenStack Cloud 7 (aarch64 s390x x86_64):
    • crowbar-core-4.0+git.1548102928.52fb95504-9.43.1
    • crowbar-core-branding-upstream-4.0+git.1548102928.52fb95504-9.43.1
  • SUSE OpenStack Cloud 7 (noarch):
    • crowbar-4.0+git.1547721131.2ffa282d-7.26.1
    • crowbar-devel-4.0+git.1547721131.2ffa282d-7.26.1
    • crowbar-ha-4.0+git.1546543083.abaa442-4.43.1
    • crowbar-openstack-4.0+git.1548443137.480904fb4-9.48.1
    • crowbar-ui-1.1.0+git.1547500033.d0fb2bf2-4.9.1
  • SUSE Enterprise Storage 4 (aarch64 x86_64):
    • crowbar-core-4.0+git.1548102928.52fb95504-9.43.1
  • SUSE Enterprise Storage 4 (noarch):
    • crowbar-4.0+git.1547721131.2ffa282d-7.26.1

References: