Recommended update for libstorage-ng

SUSE Recommended Update: Recommended update for libstorage-ng
Announcement ID: SUSE-RU-2019:0460-1
Rating: moderate
References: #1101870 #1120070
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15
  • SUSE Linux Enterprise Installer 15

An update that has two recommended fixes can now be installed.

Description:

This update for libstorage-ng fixes the following issues:

  • Fix partitioning error by relaxing the check for luks correctness. (bsc#1120070, bsc#1101870)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-460=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-460=1
  • SUSE Linux Enterprise Installer 15:
    zypper in -t patch SUSE-SLE-INSTALLER-15-2019-460=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-debuginfo-3.3.317-3.22.5
    • libstorage-ng-debugsource-3.3.317-3.22.5
    • libstorage-ng-integration-tests-3.3.317-3.22.5
    • libstorage-ng-python3-3.3.317-3.22.5
    • libstorage-ng-python3-debuginfo-3.3.317-3.22.5
    • libstorage-ng-utils-3.3.317-3.22.5
    • libstorage-ng-utils-debuginfo-3.3.317-3.22.5
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-debuginfo-3.3.317-3.22.5
    • libstorage-ng-debugsource-3.3.317-3.22.5
    • libstorage-ng-devel-3.3.317-3.22.5
    • libstorage-ng-ruby-3.3.317-3.22.5
    • libstorage-ng-ruby-debuginfo-3.3.317-3.22.5
    • libstorage-ng1-3.3.317-3.22.5
    • libstorage-ng1-debuginfo-3.3.317-3.22.5
  • SUSE Linux Enterprise Module for Basesystem 15 (noarch):
    • libstorage-ng-lang-3.3.317-3.22.5
  • SUSE Linux Enterprise Installer 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-ruby-3.3.317-3.22.5
    • libstorage-ng1-3.3.317-3.22.5
  • SUSE Linux Enterprise Installer 15 (noarch):
    • libstorage-ng-lang-3.3.317-3.22.5

References: