Recommended update for grub2

SUSE Recommended Update: Recommended update for grub2
Announcement ID: SUSE-RU-2019:0254-1
Rating: moderate
References: #1114754
Affected Products:
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for grub2 fixes the following issues:

  • Fixed possible install media boot issues on certain hardware by changing default tsc calibration method to pmtimer on EFI. (bsc#1114754)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-254=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-254=1

Package List:

  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • grub2-2.02-12.6.2
    • grub2-debuginfo-2.02-12.6.2
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 s390x x86_64):
    • grub2-debugsource-2.02-12.6.2
  • SUSE Linux Enterprise Server 12-SP4 (ppc64le):
    • grub2-powerpc-ieee1275-2.02-12.6.2
  • SUSE Linux Enterprise Server 12-SP4 (aarch64):
    • grub2-arm64-efi-2.02-12.6.2
  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • grub2-snapper-plugin-2.02-12.6.2
    • grub2-systemd-sleep-plugin-2.02-12.6.2
    • grub2-x86_64-xen-2.02-12.6.2
  • SUSE Linux Enterprise Server 12-SP4 (x86_64):
    • grub2-i386-pc-2.02-12.6.2
    • grub2-x86_64-efi-2.02-12.6.2
  • SUSE Linux Enterprise Server 12-SP4 (s390x):
    • grub2-s390x-emu-2.02-12.6.2
  • SUSE Linux Enterprise Desktop 12-SP4 (x86_64):
    • grub2-2.02-12.6.2
    • grub2-debuginfo-2.02-12.6.2
    • grub2-debugsource-2.02-12.6.2
    • grub2-i386-pc-2.02-12.6.2
    • grub2-x86_64-efi-2.02-12.6.2
  • SUSE Linux Enterprise Desktop 12-SP4 (noarch):
    • grub2-snapper-plugin-2.02-12.6.2
    • grub2-systemd-sleep-plugin-2.02-12.6.2
    • grub2-x86_64-xen-2.02-12.6.2

References: