Recommended update for google-compute-engine

SUSE Recommended Update: Recommended update for google-compute-engine
Announcement ID: SUSE-RU-2019:0201-1
Rating: moderate
References: #1119029 #1119110 #1122172
Affected Products:
  • SUSE Linux Enterprise Module for Public Cloud 15

An update that has three recommended fixes can now be installed.

Description:

This update for google-compute-engine provides the following fixes:

  • Fixes from version 20181206 (bsc#1119029, bsc#1119110): + Google Compute Engine * Support enabling OS Login two factor authentication. * Improve accounts support for FreeBSD. + Google Compute Engine OS Login * Support OS Login two factor authentication (Alpha). * Improve SELinux support.
  • Fixes from version 20181023: + Google Compute Engine * Fix: Update sudoer group membership without overriding local groups.
  • Fixes from version 20181018: + Google Compute Engine * Fix: Remove users from sudoers group on account removal.
  • Fixes from version 20181011: + Google Compute Engine * Revert: Remove users from sudoers group on account removal.
  • Fixes from version 20181008: + Google Compute Engine * Remove users from sudoers group on account removal. * Remove gsutil dependency for metadata scripts.
  • Fixes from version 20180905: + Google Compute Engine * Remove ntp package dependency. * Support Debian 10 Buster. * Restart the network daemon if networking is restarted. * Prevent setup of the default ethernet interface. * Accounts daemon verifies username is 32 characters or less. + Google Compute Engine OS Login * Add user name validation to pam modules. * Return false on failed final load. * Support FreeBSD. * Support Debian 10 Buster.
  • Fixes from version 20180611: + Google Compute Engine * Prevent IP forwarding daemon log spam. * Make default shell configurable when executing metadata scripts. * Rename distro directory to distro_lib.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Public Cloud 15:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-2019-201=1

Package List:

  • SUSE Linux Enterprise Module for Public Cloud 15 (aarch64 ppc64le s390x x86_64):
    • google-compute-engine-oslogin-20181206-4.8.1
    • google-compute-engine-oslogin-debuginfo-20181206-4.8.1
  • SUSE Linux Enterprise Module for Public Cloud 15 (noarch):
    • google-compute-engine-init-20181206-4.8.1

References: