Recommended update for slurm

SUSE Recommended Update: Recommended update for slurm
Announcement ID: SUSE-RU-2018:3097-2
Rating: moderate
References: #1108671 #1109373
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15

An update that has two recommended fixes can now be installed.

Description:

This update for slurm fixes the following issues:

  • Added correct link flags for perl bindings. (bsc#1108671)
  • Fix Requires(pre) and Requires(post) for slurm-config and slurm-node. This fixes issues with failing slurm user creation when installed during initial system installation (bsc#1109373).

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-944=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • slurm-debuginfo-17.11.9-6.12.1
    • slurm-debugsource-17.11.9-6.12.1
    • slurm-openlava-17.11.9-6.12.1
    • slurm-seff-17.11.9-6.12.1
    • slurm-sjstat-17.11.9-6.12.1
    • slurm-sview-17.11.9-6.12.1
    • slurm-sview-debuginfo-17.11.9-6.12.1

References: