Security update for perl

SUSE Security Update: Security update for perl
Announcement ID: SUSE-SU-2018:4187-1
Rating: moderate
References: #1114674 #1114675 #1114681 #1114686
Cross-References: CVE-2018-18311 CVE-2018-18312 CVE-2018-18313 CVE-2018-18314
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes four vulnerabilities is now available.

Description:

This update for perl fixes the following issues:
Secuirty issues fixed:

  • CVE-2018-18311: Fixed integer overflow with oversize environment (bsc#1114674).
  • CVE-2018-18312: Fixed heap-buffer-overflow write / reg_node overrun (bsc#1114675).
  • CVE-2018-18313: Fixed heap-buffer-overflow read if regex contains \0 chars (bsc#1114681).
  • CVE-2018-18314: Fixed heap-buffer-overflow in regex (bsc#1114686).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2018-2984=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2984=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15 (noarch):
    • perl-doc-5.26.1-7.6.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • perl-5.26.1-7.6.1
    • perl-base-5.26.1-7.6.1
    • perl-base-debuginfo-5.26.1-7.6.1
    • perl-debuginfo-5.26.1-7.6.1
    • perl-debugsource-5.26.1-7.6.1
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • perl-32bit-debuginfo-5.26.1-7.6.1
    • perl-base-32bit-5.26.1-7.6.1
    • perl-base-32bit-debuginfo-5.26.1-7.6.1

References: