Security update for kvm

SUSE Security Update: Security update for kvm
Announcement ID: SUSE-SU-2018:2615-1
Rating: moderate
References: #1092885 #1096223 #1098735
Cross-References: CVE-2018-11806 CVE-2018-12617 CVE-2018-3639
Affected Products:
  • SUSE Linux Enterprise Server 11-SP3-LTSS
  • SUSE Linux Enterprise Point of Sale 11-SP3

An update that fixes three vulnerabilities is now available.

Description:

This update for kvm fixes the following security issues:

  • CVE-2018-12617: qmp_guest_file_read had an integer overflow that could have been exploited by sending a crafted QMP command (including guest-file-read with a large count value) to the agent via the listening socket causing DoS (bsc#1098735)
  • CVE-2018-11806: Prevent heap-based buffer overflow via incoming fragmented datagrams (bsc#1096223)

With this release the mitigations for Spectre v4 are moved the the patches from upstream (CVE-2018-3639, bsc#1092885).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP3-LTSS:
    zypper in -t patch slessp3-kvm-13767=1
  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-kvm-13767=1

Package List:

  • SUSE Linux Enterprise Server 11-SP3-LTSS (i586 s390x x86_64):
    • kvm-1.4.2-53.23.2
  • SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
    • kvm-1.4.2-53.23.2

References: