Security update for shadow

SUSE Security Update: Security update for shadow
Announcement ID: SUSE-SU-2018:1997-2
Rating: important
References: #1099310
Cross-References: CVE-2016-6252
Affected Products:
  • SUSE Linux Enterprise Server 12-SP2-BCL

An update that fixes one vulnerability is now available.

Description:

This update for shadow fixes the following issues:

  • CVE-2016-6252: Incorrect integer handling could results in local privilege escalation (bsc#1099310)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP2-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-1351=1

Package List:

  • SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):
    • shadow-4.2.1-27.9.1
    • shadow-debuginfo-4.2.1-27.9.1
    • shadow-debugsource-4.2.1-27.9.1

References: