Recommended update for openvswitch

SUSE Recommended Update: Recommended update for openvswitch
Announcement ID: SUSE-RU-2018:4234-1
Rating: moderate
References: #1110865 #1112703 #1115085
Affected Products:
  • SUSE Linux Enterprise Server 12-SP4

An update that has three recommended fixes can now be installed.

Description:

This is an update for openvswitch to version 2.8.5. The update addressed a lot of issues. For a detailed overview of all the addressed issues, please visit our bug tracker (bsc#1112703).
It also has some improvements for the python packaging (bsc#1115085): * Rename python*-openvswitch subpackages to python*-ovs to follow the openSUSE policy that packages should be named after the modules they install. * Build the JSON C bindings and as a result the 'noarch' BuildArch needs to be removed. * Drop the python*-openvswitch-test packages and merge them with the test subpackage. * Build the python bindings using setuptools. * Include the egg-info package. * Use libopenvswitch as dependency to python bindings.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2018-3039=1

Package List:

  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libopenvswitch-2_8-0-2.8.5-4.6.1
    • libopenvswitch-2_8-0-debuginfo-2.8.5-4.6.1
    • openvswitch-2.8.5-4.6.1
    • openvswitch-debuginfo-2.8.5-4.6.1
    • openvswitch-debugsource-2.8.5-4.6.1

References: