Recommended update for lio-utils

SUSE Recommended Update: Recommended update for lio-utils
Announcement ID: SUSE-RU-2018:4222-1
Rating: moderate
References: #1099520 #1108982
Affected Products:
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Server 12-SP3

An update that has two recommended fixes can now be installed.

Description:

This update for lio-utils provides the following fixes:

  • Ensure deprecated target.service conflicts with targetcli.service, so that they are not executed at the same time. (bsc#1099520)
  • Ensure that the generated script lio_setup.sh ends with success by properly returning its exit status. (bsc#1108982)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2018-3038=1
  • SUSE Linux Enterprise Server 12-SP3:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-3038=1

Package List:

  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • lio-mibs-4.1-17.3.2
    • lio-mibs-debuginfo-4.1-17.3.2
    • lio-utils-4.1-17.3.2
    • lio-utils-debuginfo-4.1-17.3.2
    • lio-utils-debugsource-4.1-17.3.2
  • SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
    • lio-mibs-4.1-17.3.2
    • lio-mibs-debuginfo-4.1-17.3.2
    • lio-utils-4.1-17.3.2
    • lio-utils-debuginfo-4.1-17.3.2
    • lio-utils-debugsource-4.1-17.3.2

References: