Recommended update for plymouth

SUSE Recommended Update: Recommended update for plymouth
Announcement ID: SUSE-RU-2018:4096-1
Rating: moderate
References: #1110199
Affected Products:
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has one recommended fix can now be installed.

Description:

This update for plymouth provides the following fixes:

  • Make sure plymouthd stops throbber animation at the first opportunity after receiving quit command, instead of looping multiple times. (bsc#1110199)
  • drm: Use preferred mode for outputs.
  • drm: Refactor ply_renderer_connector_get_rotation.
  • drm: Reset LUT/gamma table before the first drmModeSetCrtc call.
  • libply: Move kernel command line parsing functions to libply/ply-utils.
  • throbber: Don't skip last frame when waiting for end.
  • systemd-units: Add "ConditionVirtualization=!container" in systemd-ask-password-plymouth.path.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15:
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2018-2924=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2018-2924=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2924=1

Package List:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15 (aarch64 ppc64le s390x x86_64):
    • plymouth-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-debugsource-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-label-ft-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-label-ft-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • plymouth-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-debugsource-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-fade-throbber-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-fade-throbber-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-label-ft-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-label-ft-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-space-flares-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-space-flares-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-throbgress-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-throbgress-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-tribar-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-tribar-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-two-step-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-two-step-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • plymouth-theme-fade-in-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-theme-script-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-theme-solar-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-theme-spinfinity-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-theme-spinner-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-theme-tribar-0.9.4+git20181111.118c5ca-4.12.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libply-boot-client4-0.9.4+git20181111.118c5ca-4.12.1
    • libply-boot-client4-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • libply-splash-core4-0.9.4+git20181111.118c5ca-4.12.1
    • libply-splash-core4-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • libply-splash-graphics4-0.9.4+git20181111.118c5ca-4.12.1
    • libply-splash-graphics4-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • libply4-0.9.4+git20181111.118c5ca-4.12.1
    • libply4-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-debugsource-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-devel-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-dracut-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-label-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-label-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-script-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-plugin-script-debuginfo-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-scripts-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-x11-renderer-0.9.4+git20181111.118c5ca-4.12.1
    • plymouth-x11-renderer-debuginfo-0.9.4+git20181111.118c5ca-4.12.1

References: