Recommended update for llvm5

SUSE Recommended Update: Recommended update for llvm5
Announcement ID: SUSE-RU-2018:3820-1
Rating: moderate
References: #1111190
Affected Products:
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has one recommended fix can now be installed.

Description:

This update for llvm5 fixes the following issues:

  • Build TableGen component as its own shared library because it is not included in the libLLVM library and is needed for ldc. (bsc#1111190)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15:
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-2018-2716=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2018-2716=1
  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2018-2716=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2716=1

Package List:

  • SUSE Linux Enterprise Module for Packagehub Subpackages 15 (x86_64):
    • liblldb5-5.0.1-8.5.1
    • liblldb5-debuginfo-5.0.1-8.5.1
    • llvm5-debuginfo-5.0.1-8.5.1
    • llvm5-debugsource-5.0.1-8.5.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • lld5-5.0.1-8.5.1
    • lld5-debuginfo-5.0.1-8.5.1
    • llvm5-debuginfo-5.0.1-8.5.1
    • llvm5-debugsource-5.0.1-8.5.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • llvm5-emacs-plugins-5.0.1-8.5.1
    • llvm5-opt-viewer-5.0.1-8.5.1
    • llvm5-vim-plugins-5.0.1-8.5.1
    • python3-clang-5.0.1-8.5.1
  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • clang5-checker-5.0.1-8.5.1
    • llvm5-debuginfo-5.0.1-8.5.1
    • llvm5-debugsource-5.0.1-8.5.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • clang5-5.0.1-8.5.1
    • clang5-debuginfo-5.0.1-8.5.1
    • clang5-devel-5.0.1-8.5.1
    • libLLVM5-5.0.1-8.5.1
    • libLLVM5-debuginfo-5.0.1-8.5.1
    • libLTO5-5.0.1-8.5.1
    • libLTO5-debuginfo-5.0.1-8.5.1
    • libclang5-5.0.1-8.5.1
    • libclang5-debuginfo-5.0.1-8.5.1
    • llvm5-5.0.1-8.5.1
    • llvm5-LTO-devel-5.0.1-8.5.1
    • llvm5-debuginfo-5.0.1-8.5.1
    • llvm5-debugsource-5.0.1-8.5.1
    • llvm5-devel-5.0.1-8.5.1
    • llvm5-devel-debuginfo-5.0.1-8.5.1
    • llvm5-gold-5.0.1-8.5.1
    • llvm5-gold-debuginfo-5.0.1-8.5.1
  • SUSE Linux Enterprise Module for Basesystem 15 (ppc64le x86_64):
    • libomp5-devel-5.0.1-8.5.1
    • libomp5-devel-debuginfo-5.0.1-8.5.1
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • libLLVM5-32bit-5.0.1-8.5.1
    • libLLVM5-32bit-debuginfo-5.0.1-8.5.1
    • libc++-devel-5.0.1-8.5.1
    • libc++1-5.0.1-8.5.1
    • libc++1-debuginfo-5.0.1-8.5.1
    • libc++abi-devel-5.0.1-8.5.1
    • libc++abi1-5.0.1-8.5.1
    • libc++abi1-debuginfo-5.0.1-8.5.1

References: