Recommended update for plymouth

SUSE Recommended Update: Recommended update for plymouth
Announcement ID: SUSE-RU-2018:3543-1
Rating: low
References: #1043834 #1083695 #804607 #894051
Affected Products:
  • SUSE OpenStack Cloud 7
  • SUSE Linux Enterprise Software Development Kit 12-SP3
  • SUSE Linux Enterprise Server for SAP 12-SP2
  • SUSE Linux Enterprise Server 12-SP3
  • SUSE Linux Enterprise Server 12-SP2-LTSS
  • SUSE Linux Enterprise Server 12-SP2-BCL
  • SUSE Linux Enterprise Desktop 12-SP3
  • SUSE Enterprise Storage 4

An update that has four recommended fixes can now be installed.

Description:

This update for plymouth fixes the following issues:

  • Fix an infinite loop by skipping new line characters on multiline text. (bsc#1083695)
  • Ship license file with package. (bsc#1043834)
  • Drop a previous fix for window size and use of the smallest screen size deliberately. (bsc#804607, bsc#894051)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud 7:
    zypper in -t patch SUSE-OpenStack-Cloud-7-2018-2510=1
  • SUSE Linux Enterprise Software Development Kit 12-SP3:
    zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-2510=1
  • SUSE Linux Enterprise Server for SAP 12-SP2:
    zypper in -t patch SUSE-SLE-SAP-12-SP2-2018-2510=1
  • SUSE Linux Enterprise Server 12-SP3:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-2510=1
  • SUSE Linux Enterprise Server 12-SP2-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-2510=1
  • SUSE Linux Enterprise Server 12-SP2-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-2510=1
  • SUSE Linux Enterprise Desktop 12-SP3:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-2510=1
  • SUSE Enterprise Storage 4:
    zypper in -t patch SUSE-Storage-4-2018-2510=1

Package List:

  • SUSE OpenStack Cloud 7 (s390x x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-tribar-0.9.2-35.9.1
    • plymouth-plugin-tribar-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1
  • SUSE OpenStack Cloud 7 (noarch):
    • plymouth-theme-tribar-0.9.2-35.9.1
  • SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-devel-0.9.2-35.9.1
    • plymouth-plugin-tribar-0.9.2-35.9.1
    • plymouth-plugin-tribar-debuginfo-0.9.2-35.9.1
    • plymouth-x11-renderer-0.9.2-35.9.1
    • plymouth-x11-renderer-debuginfo-0.9.2-35.9.1
  • SUSE Linux Enterprise Software Development Kit 12-SP3 (noarch):
    • plymouth-theme-tribar-0.9.2-35.9.1
  • SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-tribar-0.9.2-35.9.1
    • plymouth-plugin-tribar-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1
  • SUSE Linux Enterprise Server for SAP 12-SP2 (noarch):
    • plymouth-theme-tribar-0.9.2-35.9.1
  • SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-tribar-0.9.2-35.9.1
    • plymouth-plugin-tribar-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS (noarch):
    • plymouth-theme-tribar-0.9.2-35.9.1
  • SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-tribar-0.9.2-35.9.1
    • plymouth-plugin-tribar-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1
  • SUSE Linux Enterprise Server 12-SP2-BCL (noarch):
    • plymouth-theme-tribar-0.9.2-35.9.1
  • SUSE Linux Enterprise Desktop 12-SP3 (x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1
  • SUSE Enterprise Storage 4 (noarch):
    • plymouth-theme-tribar-0.9.2-35.9.1
  • SUSE Enterprise Storage 4 (x86_64):
    • libply-boot-client4-0.9.2-35.9.1
    • libply-boot-client4-debuginfo-0.9.2-35.9.1
    • libply-splash-core4-0.9.2-35.9.1
    • libply-splash-core4-debuginfo-0.9.2-35.9.1
    • libply-splash-graphics4-0.9.2-35.9.1
    • libply-splash-graphics4-debuginfo-0.9.2-35.9.1
    • libply4-0.9.2-35.9.1
    • libply4-debuginfo-0.9.2-35.9.1
    • plymouth-0.9.2-35.9.1
    • plymouth-debuginfo-0.9.2-35.9.1
    • plymouth-debugsource-0.9.2-35.9.1
    • plymouth-dracut-0.9.2-35.9.1
    • plymouth-plugin-label-0.9.2-35.9.1
    • plymouth-plugin-label-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-label-ft-0.9.2-35.9.1
    • plymouth-plugin-label-ft-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-script-0.9.2-35.9.1
    • plymouth-plugin-script-debuginfo-0.9.2-35.9.1
    • plymouth-plugin-tribar-0.9.2-35.9.1
    • plymouth-plugin-tribar-debuginfo-0.9.2-35.9.1
    • plymouth-scripts-0.9.2-35.9.1

References: