Recommended update for openmpi

SUSE Recommended Update: Recommended update for openmpi
Announcement ID: SUSE-RU-2018:3320-1
Rating: moderate
References: #1041090 #1047218 #1084909 #1094689 #1098653
Affected Products:
  • SUSE Linux Enterprise Module for Legacy Software 15

An update that has 5 recommended fixes can now be installed.

Description:

This update for openmpi fixes the following issues:

  • Fix handling of mpi-selector during updates (bsc#1098653)
  • Make package build reproducible (bsc#1047218, bsc#1084909, bsc#1041090)
  • Add support for newer HCA (bsc#1094689)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Legacy Software 15:
    zypper in -t patch SUSE-SLE-Module-Legacy-15-2018-2384=1

Package List:

  • SUSE Linux Enterprise Module for Legacy Software 15 (aarch64 ppc64le s390x x86_64):
    • openmpi-1.10.7-13.3.1
    • openmpi-config-1.10.7-13.3.1
    • openmpi-debuginfo-1.10.7-13.3.1
    • openmpi-debugsource-1.10.7-13.3.1
    • openmpi-devel-1.10.7-13.3.1
    • openmpi-devel-debuginfo-1.10.7-13.3.1
    • openmpi-libs-1.10.7-13.3.1
    • openmpi-libs-debuginfo-1.10.7-13.3.1

References: