Recommended update for yast2-storage-ng and libstorage-ng

SUSE Recommended Update: Recommended update for yast2-storage-ng and libstorage-ng
Announcement ID: SUSE-RU-2018:3307-1
Rating: moderate
References: #1055756 #1085134 #1089353 #1090010 #1099144 #1099181 #1099394 #1099762 #1103113 #1104774 #1105227 #1106774 #1107298 #1108831
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15
  • SUSE Linux Enterprise Installer 15

An update that has 14 recommended fixes can now be installed.

Description:

This update for yast2-storage-ng and libstorage-ng fixes the following issues:
yast2-storage-ng:

  • When trying to reuse a partition, AutoYaST will consider only those partitions from the right disk (bsc#1106774).
  • Show a warning when overwriting manually edited settings (bsc#1055756)
  • AutoYaST: Export volume group name (lvm_group) when an MD RAID device is used as a physical volume (bsc#1103113).
  • AutoYaST: Recognize Xen virtual partitions in the profile when importing and installing (bsc#1085134).
  • AutoYaST: Set the 'mount by' option when reusing partitions (bsc#1104774).
  • Fixed the warning about overwriting a manually edited partition layout. Now it works even after going back and forth in the installer steps (bsc#1055756).
  • Partitioner: Display Xen virtual partitions and allow to format and mount them (bsc#1085134).
  • RAID attributes: Include "Active: Yes/No". (bsc#1090010)
  • Fixed crash in the Kubic proposal when insufficient disk space. (bsc#1099762)
  • Allow to use whole disk as PV by indicating a partition with number 0 (bsc#1107298)
  • Add asterisk to mount points that is not active and to the description (fate#318196)
  • Does no longer crash if existing boot partition cannot be used without formatting it (bsc#1108831)

libstorage-ng:
  • Fixed variable scope to fix temporary mounting. (bsc#1099144)
  • Avoid exceptions for inactive RAIDs. (bsc#1090010)
  • Adjust multipath parser to accept nvme related output. (bsc#1089353)
  • Detect correctly whether a file system is currently mounted. (bsc#1105227)
  • Do not crash when displaying summary for an encrypted but not mounted disk (bsc#1099181)
  • Improve handling of udev ids starting with dm-uuid for partitions on multipath (bsc#1099394)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2389=1
  • SUSE Linux Enterprise Installer 15:
    zypper in -t patch SUSE-SLE-INSTALLER-15-2018-2389=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-debuginfo-3.3.315-3.16.3
    • libstorage-ng-debugsource-3.3.315-3.16.3
    • libstorage-ng-devel-3.3.315-3.16.3
    • libstorage-ng-ruby-3.3.315-3.16.3
    • libstorage-ng-ruby-debuginfo-3.3.315-3.16.3
    • libstorage-ng1-3.3.315-3.16.3
    • libstorage-ng1-debuginfo-3.3.315-3.16.3
    • yast2-storage-ng-4.0.213-3.26.1
  • SUSE Linux Enterprise Module for Basesystem 15 (noarch):
    • libstorage-ng-lang-3.3.315-3.16.3
  • SUSE Linux Enterprise Installer 15 (aarch64 ppc64le s390x x86_64):
    • libstorage-ng-debuginfo-3.3.315-3.16.3
    • libstorage-ng-debugsource-3.3.315-3.16.3
    • libstorage-ng-devel-3.3.315-3.16.3
    • libstorage-ng-ruby-3.3.315-3.16.3
    • libstorage-ng-ruby-debuginfo-3.3.315-3.16.3
    • libstorage-ng1-3.3.315-3.16.3
    • libstorage-ng1-debuginfo-3.3.315-3.16.3
    • yast2-storage-ng-4.0.213-3.26.1
  • SUSE Linux Enterprise Installer 15 (noarch):
    • libstorage-ng-lang-3.3.315-3.16.3

References: