Recommended update for hawk2

SUSE Recommended Update: Recommended update for hawk2
Announcement ID: SUSE-RU-2018:3098-1
Rating: moderate
References: #1069296 #1076421 #1080439 #1083511 #1085515 #1089802 #1090562 #1090657 #1090667 #1092108
Affected Products:
  • SUSE Linux Enterprise High Availability 12-SP3

An update that has 10 recommended fixes can now be installed.

Description:

This update for hawk2 fixes the following issues:

  • Fix remote nodes iteration (bsc#1080439)
  • Handle failure to fetch cluster name-bsc (bsc#1083511)
  • Return after redirect in reports (bsc#1090562)
  • Fix acl_enabled (bsc#1069296)
  • Fix acl_version check (bsc#1089802)
  • Make resource stop/start icon dependent on target-role (bsc#1076421)
  • Set Symmetrical to False when score is Serialize (bsc#1085515)
  • Improve hawk-server side cookie handling (bsc#1090667)
  • Set secure flag to enforce https (bsc#1090657)
  • Remove json extension from javascript delete operations (bsc#1092108)
  • Comply routes' id with resources' ID (bsc#1092108)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 12-SP3:
    zypper in -t patch SUSE-SLE-HA-12-SP3-2018-2199=1

Package List:

  • SUSE Linux Enterprise High Availability 12-SP3 (ppc64le s390x x86_64):
    • hawk2-2.1.0+git.1516013868.bada8da4-2.13.1
    • hawk2-debuginfo-2.1.0+git.1516013868.bada8da4-2.13.1
    • hawk2-debugsource-2.1.0+git.1516013868.bada8da4-2.13.1

References: