Recommended update for snapper

SUSE Recommended Update: Recommended update for snapper
Announcement ID: SUSE-RU-2018:2909-1
Rating: moderate
References: #1096208 #1096401
Affected Products:
  • SUSE Linux Enterprise Module for Basesystem 15

An update that has two recommended fixes can now be installed.

Description:

This update for snapper fixes the following issues:

  • Fixed logging during shutdown of snapperd to avoid core dumps. (bsc#1096401)
  • Fix fails to build with new Boost library due to missing pthread library during link. (bsc#1096208)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2067=1

Package List:

  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libsnapper-devel-0.5.6-5.3.1
    • libsnapper4-0.5.6-5.3.1
    • libsnapper4-debuginfo-0.5.6-5.3.1
    • pam_snapper-0.5.6-5.3.1
    • pam_snapper-debuginfo-0.5.6-5.3.1
    • snapper-0.5.6-5.3.1
    • snapper-debuginfo-0.5.6-5.3.1
    • snapper-debugsource-0.5.6-5.3.1
  • SUSE Linux Enterprise Module for Basesystem 15 (noarch):
    • snapper-zypp-plugin-0.5.6-5.3.1

References: