Recommended update for rollback-helper

SUSE Recommended Update: Recommended update for rollback-helper
Announcement ID: SUSE-RU-2018:1280-2
Rating: important
References: #1011912 #1032129 #1068947 #1090073
Affected Products:
  • SUSE Linux Enterprise Server 12-SP2-BCL

An update that has four recommended fixes can now be installed.

Description:

This update for rollback-helper fixes the following issues:

  • Check whether system is registered before rollback (bsc#1032129)
  • Check if current btrfs snapshot is the production snapshot before re-registering (bsc#1068947)
  • Add missing systemd requirement (bsc#1011912)
  • Make sure rollback-helper is started only after all filesystems are accessible. This makes sure that checking for the correct snapshot is properly done and prevents it from thinking there is nothing to do. (bsc#1090073)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP2-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-901=1

Package List:

  • SUSE Linux Enterprise Server 12-SP2-BCL (noarch):
    • rollback-helper-1.0+git20180419.3c7281d-7.3.1

References: