Security update for tomcat

SUSE Security Update: Security update for tomcat
Announcement ID: SUSE-SU-2017:3059-1
Rating: important
References: #1042910 #1053352 #1059551 #1059554 #977410
Affected Products:
  • SUSE Linux Enterprise Server 12-LTSS

  • An update that fixes 5 vulnerabilities is now available.

    Description:



    Apache Tomcat was updated to 7.0.82 adding features, fixing bugs and
    security issues.

    This is another bugfix release, for full details see:

    https://tomcat.apache.org/tomcat-7.0-doc/changelog.html

    Fixed security issues:

    - CVE-2017-5664: A problem in handling error pages was fixed, to avoid
    potential file overwrites during error page handling. (bsc#1042910).
    - CVE-2017-7674: A CORS Filter issue could lead to client and server side
    cache poisoning (bsc#1053352)
    - CVE-2017-12617: A remote code execution possibility via JSP Upload was
    fixed (bsc#1059554)
    - CVE-2017-12616: An information disclosure when using VirtualDirContext
    was fixed (bsc#1059551)
    - CVE-2017-12615: A Remote Code Execution via JSP Upload was fixed
    (bsc#1059554)

    Non-security issues fixed:

    - Fix tomcat-digest classpath error (bsc#977410)

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 12-LTSS:
      zypper in -t patch SUSE-SLE-SERVER-12-2017-1889=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 12-LTSS (noarch):
      • tomcat-7.0.82-7.16.1
      • tomcat-admin-webapps-7.0.82-7.16.1
      • tomcat-docs-webapp-7.0.82-7.16.1
      • tomcat-el-2_2-api-7.0.82-7.16.1
      • tomcat-javadoc-7.0.82-7.16.1
      • tomcat-jsp-2_2-api-7.0.82-7.16.1
      • tomcat-lib-7.0.82-7.16.1
      • tomcat-servlet-3_0-api-7.0.82-7.16.1
      • tomcat-webapps-7.0.82-7.16.1

    References: