Security update for xen

SUSE Security Update: Security update for xen
Announcement ID: SUSE-SU-2017:2856-1
Rating: important
References: #1027519 #1059777 #1061076 #1061080 #1061081 #1061082 #1061084 #1061086 #1061087
Affected Products:
  • SUSE Linux Enterprise Server 12-LTSS

  • An update that solves 8 vulnerabilities and has one errata is now available.

    Description:

    This update for xen fixes several issues:

    These security issues were fixed:

    - CVE-2017-5526: The ES1370 audio device emulation support was vulnerable
    to a memory leakage issue allowing a privileged user inside the guest to
    cause a DoS and/or potentially crash the Qemu process on the host
    (bsc#1059777)
    - CVE-2017-15593: Missing cleanup in the page type system allowed a
    malicious or buggy PV guest to cause DoS (XSA-242 bsc#1061084)
    - CVE-2017-15592: A problem in the shadow pagetable code allowed a
    malicious or buggy HVM guest to cause DoS or cause hypervisor memory
    corruption potentially allowing the guest to escalate its privilege
    (XSA-243 bsc#1061086)
    - CVE-2017-15594: Problematic handling of the selector fields in the
    Interrupt Descriptor Table (IDT) allowed a malicious or buggy x86 PV
    guest to escalate its privileges or cause DoS (XSA-244 bsc#1061087)
    - CVE-2017-15589: Intercepted I/O write operations with less than a full
    machine word's worth of data were not properly handled, which allowed a
    malicious unprivileged x86 HVM guest to obtain sensitive information
    from the host or
    other guests (XSA-239 bsc#1061080)
    - CVE-2017-15595: In certain configurations of linear page tables a stack
    overflow might have occured that allowed a malicious or buggy PV guest
    to cause DoS and potentially privilege escalation and information leaks
    (XSA-240 bsc#1061081)
    - CVE-2017-15588: Under certain conditions x86 PV guests could have caused
    the hypervisor to miss a necessary TLB flush for a page. This allowed a
    malicious x86 PV guest to access all of system memory, allowing for
    privilege escalation, DoS, and information leaks (XSA-241 bsc#1061082)
    - CVE-2017-15590: Multiple issues existed with the setup of PCI MSI
    interrupts that allowed a malicious or buggy guest to cause DoS and
    potentially privilege escalation and information leaks (XSA-237
    bsc#1061076)

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 12-LTSS:
      zypper in -t patch SUSE-SLE-SERVER-12-2017-1778=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 12-LTSS (x86_64):
      • xen-4.4.4_24-22.54.1
      • xen-debugsource-4.4.4_24-22.54.1
      • xen-doc-html-4.4.4_24-22.54.1
      • xen-kmp-default-4.4.4_24_k3.12.61_52.92-22.54.1
      • xen-kmp-default-debuginfo-4.4.4_24_k3.12.61_52.92-22.54.1
      • xen-libs-32bit-4.4.4_24-22.54.1
      • xen-libs-4.4.4_24-22.54.1
      • xen-libs-debuginfo-32bit-4.4.4_24-22.54.1
      • xen-libs-debuginfo-4.4.4_24-22.54.1
      • xen-tools-4.4.4_24-22.54.1
      • xen-tools-debuginfo-4.4.4_24-22.54.1
      • xen-tools-domU-4.4.4_24-22.54.1
      • xen-tools-domU-debuginfo-4.4.4_24-22.54.1

    References: