Security update for qemu

SUSE Security Update: Security update for qemu
Announcement ID: SUSE-SU-2016:2936-1
Rating: important
References: #1001151 #1002116 #1002550 #1002557 #1003878 #1003893 #1003894 #1004702 #1004707 #1006536 #1006538 #1007391 #1007450 #1007454 #1007493 #1007494 #1007495 #998516 #999661
Affected Products:
  • SUSE Linux Enterprise Server for SAP 12
  • SUSE Linux Enterprise Server 12-LTSS

  • An update that solves 18 vulnerabilities and has one errata is now available.

    Description:


    This update for qemu fixes the following issues:

    - Patch queue updated from https://gitlab.suse.de/virtualization/qemu.git
    SLE12
    - Change package post script udevadm trigger calls to be device specific
    (bsc#1002116)
    - Address various security/stability issues
    * Fix OOB access in xlnx.xpx-ethernetlite emulation (CVE-2016-7161
    bsc#1001151)
    * Fix OOB access in VMware SVGA emulation (CVE-2016-7170 bsc#998516)
    * Fix DOS in Vmware pv scsi interface (CVE-2016-7421 bsc#999661)
    * Fix DOS in ColdFire Fast Ethernet Controller emulation (CVE-2016-7908
    bsc#1002550)
    * Fix DOS in USB xHCI emulation (CVE-2016-8576 bsc#1003878)
    * Fix DOS in virtio-9pfs (CVE-2016-8578 bsc#1003894)
    * Fix DOS in virtio-9pfs (CVE-2016-9105 bsc#1007494)
    * Fix DOS in virtio-9pfs (CVE-2016-8577 bsc#1003893)
    * Plug data leak in virtio-9pfs interface (CVE-2016-9103 bsc#1007454)
    * Fix DOS in virtio-9pfs interface (CVE-2016-9102 bsc#1007450)
    * Fix DOS in virtio-9pfs (CVE-2016-9106 bsc#1007495)
    * Fix DOS in 16550A UART emulation (CVE-2016-8669 bsc#1004707)
    * Fix DOS in PC-Net II emulation (CVE-2016-7909 bsc#1002557)
    * Fix DOS in PRO100 emulation (CVE-2016-9101 bsc#1007391)
    * Fix DOS in RTL8139 emulation (CVE-2016-8910 bsc#1006538)
    * Fix DOS in Intel HDA controller emulation (CVE-2016-8909 bsc#1006536)
    * Fix DOS in virtio-9pfs (CVE-2016-9104 bsc#1007493)
    * Fix DOS in JAZZ RC4030 emulation (CVE-2016-8667 bsc#1004702)

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server for SAP 12:
      zypper in -t patch SUSE-SLE-SAP-12-2016-1719=1
    • SUSE Linux Enterprise Server 12-LTSS:
      zypper in -t patch SUSE-SLE-SERVER-12-2016-1719=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server for SAP 12 (x86_64):
      • qemu-2.0.2-48.25.1
      • qemu-block-curl-2.0.2-48.25.1
      • qemu-block-curl-debuginfo-2.0.2-48.25.1
      • qemu-block-rbd-2.0.2-48.25.1
      • qemu-block-rbd-debuginfo-2.0.2-48.25.1
      • qemu-debugsource-2.0.2-48.25.1
      • qemu-guest-agent-2.0.2-48.25.1
      • qemu-guest-agent-debuginfo-2.0.2-48.25.1
      • qemu-kvm-2.0.2-48.25.1
      • qemu-lang-2.0.2-48.25.1
      • qemu-tools-2.0.2-48.25.1
      • qemu-tools-debuginfo-2.0.2-48.25.1
      • qemu-x86-2.0.2-48.25.1
      • qemu-x86-debuginfo-2.0.2-48.25.1
    • SUSE Linux Enterprise Server for SAP 12 (noarch):
      • qemu-ipxe-1.0.0-48.25.1
      • qemu-seabios-1.7.4-48.25.1
      • qemu-sgabios-8-48.25.1
      • qemu-vgabios-1.7.4-48.25.1
    • SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):
      • qemu-2.0.2-48.25.1
      • qemu-block-curl-2.0.2-48.25.1
      • qemu-block-curl-debuginfo-2.0.2-48.25.1
      • qemu-debugsource-2.0.2-48.25.1
      • qemu-guest-agent-2.0.2-48.25.1
      • qemu-guest-agent-debuginfo-2.0.2-48.25.1
      • qemu-lang-2.0.2-48.25.1
      • qemu-tools-2.0.2-48.25.1
      • qemu-tools-debuginfo-2.0.2-48.25.1
    • SUSE Linux Enterprise Server 12-LTSS (s390x x86_64):
      • qemu-kvm-2.0.2-48.25.1
    • SUSE Linux Enterprise Server 12-LTSS (ppc64le):
      • qemu-ppc-2.0.2-48.25.1
      • qemu-ppc-debuginfo-2.0.2-48.25.1
    • SUSE Linux Enterprise Server 12-LTSS (x86_64):
      • qemu-block-rbd-2.0.2-48.25.1
      • qemu-block-rbd-debuginfo-2.0.2-48.25.1
      • qemu-x86-2.0.2-48.25.1
      • qemu-x86-debuginfo-2.0.2-48.25.1
    • SUSE Linux Enterprise Server 12-LTSS (noarch):
      • qemu-ipxe-1.0.0-48.25.1
      • qemu-seabios-1.7.4-48.25.1
      • qemu-sgabios-8-48.25.1
      • qemu-vgabios-1.7.4-48.25.1
    • SUSE Linux Enterprise Server 12-LTSS (s390x):
      • qemu-s390-2.0.2-48.25.1
      • qemu-s390-debuginfo-2.0.2-48.25.1

    References: