Security update for wpa_supplicant

SUSE Security Update: Security update for wpa_supplicant
Announcement ID: SUSE-SU-2016:2305-1
Rating: moderate
References: #930077 #930078 #930079 #937419 #952254
Affected Products:
  • SUSE Linux Enterprise Server 12-SP1
  • SUSE Linux Enterprise Desktop 12-SP1

  • An update that fixes 5 vulnerabilities is now available.

    Description:


    This update for wpa_supplicant fixes the following issues:

    - CVE-2015-4141: WPS UPnP vulnerability with HTTP chunked transfer
    encoding. (bnc#930077)
    - CVE-2015-4142: Integer underflow in AP mode WMM Action frame
    processing. (bnc#930078)
    - CVE-2015-4143: EAP-pwd missing payload length validation. (bnc#930079)
    - CVE-2015-5310: Ignore Key Data in WNM Sleep Mode Response frame if no
    PMF in use. (bsc#952254)
    - CVE-2015-8041: Fix payload length validation in NDEF record parser.
    (bsc#937419)

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 12-SP1:
      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-1351=1
    • SUSE Linux Enterprise Desktop 12-SP1:
      zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-1351=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 12-SP1 (ppc64le s390x x86_64):
      • wpa_supplicant-2.2-14.2
      • wpa_supplicant-debuginfo-2.2-14.2
      • wpa_supplicant-debugsource-2.2-14.2
    • SUSE Linux Enterprise Desktop 12-SP1 (x86_64):
      • wpa_supplicant-2.2-14.2
      • wpa_supplicant-debuginfo-2.2-14.2
      • wpa_supplicant-debugsource-2.2-14.2

    References: