Security update for libarchive

SUSE Security Update: Security update for libarchive
Announcement ID: SUSE-SU-2016:1909-1
Rating: important
References: #984990 #985609 #985665 #985669 #985673 #985675 #985679 #985682 #985685 #985688 #985689 #985697 #985698 #985700 #985703 #985704 #985706 #985826 #985832 #985835
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP1
  • SUSE Linux Enterprise Server 12-SP1
  • SUSE Linux Enterprise Desktop 12-SP1

  • An update that fixes 20 vulnerabilities is now available.

    Description:

    libarchive was updated to fix 20 security issues.

    These security issues were fixed:
    - CVE-2015-8918: Overlapping memcpy in CAB parser (bsc#985698).
    - CVE-2015-8919: Heap out of bounds read in LHA/LZH parser (bsc#985697).
    - CVE-2015-8920: Stack out of bounds read in ar parser (bsc#985675).
    - CVE-2015-8921: Global out of bounds read in mtree parser (bsc#985682).
    - CVE-2015-8922: Null pointer access in 7z parser (bsc#985685).
    - CVE-2015-8923: Unclear crashes in ZIP parser (bsc#985703).
    - CVE-2015-8924: Heap buffer read overflow in tar (bsc#985609).
    - CVE-2015-8925: Unclear invalid memory read in mtree parser (bsc#985706).
    - CVE-2015-8926: NULL pointer access in RAR parser (bsc#985704).
    - CVE-2015-8928: Heap out of bounds read in mtree parser (bsc#985679).
    - CVE-2015-8929: Memory leak in tar parser (bsc#985669).
    - CVE-2015-8930: Endless loop in ISO parser (bsc#985700).
    - CVE-2015-8931: Undefined behavior / signed integer overflow in mtree
    parser (bsc#985689).
    - CVE-2015-8932: Compress handler left shifting larger than int size
    (bsc#985665).
    - CVE-2015-8933: Undefined behavior / signed integer overflow in TAR
    parser (bsc#985688).
    - CVE-2015-8934: Out of bounds read in RAR (bsc#985673).
    - CVE-2016-4300: Heap buffer overflow vulnerability in the 7zip
    read_SubStreamsInfo (bsc#985832).
    - CVE-2016-4301: Stack buffer overflow in the mtree parse_device
    (bsc#985826).
    - CVE-2016-4302: Heap buffer overflow in the Rar decompression
    functionality (bsc#985835).
    - CVE-2016-4809: Memory allocate error with symbolic links in cpio
    archives (bsc#984990).

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 12-SP1:
      zypper in -t patch SUSE-SLE-SDK-12-SP1-2016-1123=1
    • SUSE Linux Enterprise Server 12-SP1:
      zypper in -t patch SUSE-SLE-SERVER-12-SP1-2016-1123=1
    • SUSE Linux Enterprise Desktop 12-SP1:
      zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2016-1123=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 12-SP1 (ppc64le s390x x86_64):
      • libarchive-debugsource-3.1.2-22.1
      • libarchive-devel-3.1.2-22.1
    • SUSE Linux Enterprise Server 12-SP1 (ppc64le s390x x86_64):
      • libarchive-debugsource-3.1.2-22.1
      • libarchive13-3.1.2-22.1
      • libarchive13-debuginfo-3.1.2-22.1
    • SUSE Linux Enterprise Desktop 12-SP1 (x86_64):
      • libarchive-debugsource-3.1.2-22.1
      • libarchive13-3.1.2-22.1
      • libarchive13-debuginfo-3.1.2-22.1

    References: