Security update for Samba

SUSE Security Update: Security update for Samba
Announcement ID: SUSE-SU-2014:0901-1
Rating: moderate
References: #437293 #726937 #786677 #844307 #849224 #863748 #865561 #872396 #879390 #880962 #883758
Affected Products:
  • SUSE Linux Enterprise Server 11 SP2 LTSS

  • An update that solves four vulnerabilities and has 7 fixes is now available.

    Description:


    Samba was updated to fix three security issues and several non-security
    issue.

    These security issues have been fixed:

    * Fix segmentation fault in smbd_marshal_dir_entry()'s
    SMB_FIND_FILE_UNIXhandler. (CVE-2014-3493)
    * Fix nmbd denial of service. (CVE-2014-0244)
    * Fix malformed FSCTL_SRV_ENUMERATE_SNAPSHOTS response. (CVE-2014-0178)
    * Pasword lockout not enforced for SAMR password changes.
    (CVE-2013-4496)

    These non-security issues have been fixed:

    * Fix printer job purging. (bso#10612, bnc#879390)
    * Depend only on %version with all manual Provides and Requires.
    (bnc#844307)
    * Fix problem with server taking too long to respond to
    aMSG_PRINTER_DRVUPGRADE message. (bso#9942, bnc#863748)
    * Fix memory leak in printer_list_get_printer(). (bso#9993, bnc#865561)
    * Depend on %version-%release with all manual Provides and Requires.
    (bnc#844307)
    * Remove superfluous obsoletes *-64bit in the ifarch ppc64 case.
    (bnc#437293)
    * Fix Winbind 100% CPU utilization caused by domain list corruption.
    (bso#10358, bnc#786677)
    * Make winbindd print the interface version when it gets an
    INTERFACE_VERSIONrequest. (bnc#726937)

    Security Issues references:

    * CVE-2014-3493

    * CVE-2014-0244

    * CVE-2014-0178

    * CVE-2013-4496

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 11 SP2 LTSS:
      zypper in -t patch slessp2-cifs-mount-9431

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 11 SP2 LTSS (i586 s390x x86_64):
      • ldapsmb-1.34b-12.33.41.2
      • libldb1-3.6.3-0.33.41.2
      • libsmbclient0-3.6.3-0.33.41.2
      • libtalloc1-3.4.3-1.54.4
      • libtalloc2-3.6.3-0.33.41.2
      • libtdb1-3.6.3-0.33.41.2
      • libtevent0-3.6.3-0.33.41.2
      • libwbclient0-3.6.3-0.33.41.2
      • samba-3.6.3-0.33.41.2
      • samba-client-3.6.3-0.33.41.2
      • samba-krb-printing-3.6.3-0.33.41.2
      • samba-winbind-3.6.3-0.33.41.2
    • SUSE Linux Enterprise Server 11 SP2 LTSS (s390x x86_64):
      • libsmbclient0-32bit-3.6.3-0.33.41.2
      • libtalloc1-32bit-3.4.3-1.54.4
      • libtalloc2-32bit-3.6.3-0.33.41.2
      • libtdb1-32bit-3.6.3-0.33.41.2
      • libtevent0-32bit-3.6.3-0.33.41.2
      • libwbclient0-32bit-3.6.3-0.33.41.2
      • samba-32bit-3.6.3-0.33.41.2
      • samba-client-32bit-3.6.3-0.33.41.2
      • samba-winbind-32bit-3.6.3-0.33.41.2
    • SUSE Linux Enterprise Server 11 SP2 LTSS (noarch):
      • samba-doc-3.6.3-0.33.41.2

    References:

    • http://support.novell.com/security/cve/CVE-2013-4496.html
    • http://support.novell.com/security/cve/CVE-2014-0178.html
    • http://support.novell.com/security/cve/CVE-2014-0244.html
    • http://support.novell.com/security/cve/CVE-2014-3493.html
    • https://bugzilla.novell.com/437293
    • https://bugzilla.novell.com/726937
    • https://bugzilla.novell.com/786677
    • https://bugzilla.novell.com/844307
    • https://bugzilla.novell.com/849224
    • https://bugzilla.novell.com/863748
    • https://bugzilla.novell.com/865561
    • https://bugzilla.novell.com/872396
    • https://bugzilla.novell.com/879390
    • https://bugzilla.novell.com/880962
    • https://bugzilla.novell.com/883758
    • http://download.suse.com/patch/finder/?keywords=e6bedb260561479f3ebed037356d594b