SUSE-SU-2014:0879-1

Security update for quagga

SUSE Security Update: Security update for quagga
Announcement ID: SUSE-SU-2014:0879-1
Rating: moderate
References: #822572 #828117
Affected Products:
  • SUSE Linux Enterprise Server 11 SP1 LTSS
  • SUSE Linux Enterprise Server 10 SP4 LTSS
  • SUSE Linux Enterprise Server 10 SP3 LTSS

  • An update that fixes two vulnerabilities is now available.

    Description:


    Quagga received an update fixing two security issues:

    * CVE-2013-2236: Stack-based buffer overflow in the
    new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in
    Quagga, when --enable-opaque-lsa and the -a command line option are
    used, allowed remote attackers to cause a denial of service (crash)
    via a large LSA.
    * CVE-2013-0149: The OSPF implementation in Quagga did not properly
    validate Link State Advertisement (LSA) type 1 packets before
    performing operations on the LSA database, which allows remote
    attackers to cause a denial of service (routing disruption) or
    obtain sensitive packet information via a (1) unicast or (2)
    multicast packet.

    Security Issues references:

    * CVE-2013-2236

    * CVE-2013-0149

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 11 SP1 LTSS:
      zypper in -t patch slessp1-quagga-9416

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 11 SP1 LTSS (i586 s390x x86_64):
      • quagga-0.99.15-0.14.11
    • SUSE Linux Enterprise Server 10 SP4 LTSS (i586 s390x x86_64):
      • quagga-0.99.9-14.17.12
      • quagga-devel-0.99.9-14.17.12
    • SUSE Linux Enterprise Server 10 SP3 LTSS (i586 s390x x86_64):
      • quagga-0.99.9-14.17.12
      • quagga-devel-0.99.9-14.17.12

    References:

    • http://support.novell.com/security/cve/CVE-2013-0149.html
    • http://support.novell.com/security/cve/CVE-2013-2236.html
    • https://bugzilla.novell.com/822572
    • https://bugzilla.novell.com/828117
    • http://download.suse.com/patch/finder/?keywords=6cc544cafa35bad90a6c69b6b80644c6
    • http://download.suse.com/patch/finder/?keywords=718958de9702ca0d22de230f19958498
    • http://download.suse.com/patch/finder/?keywords=c9f78ccd5294160085407a80780f26a7