SUSE-SU-2014:0548-1

Security update for jakarta-commons-fileupload

SUSE Security Update: Security update for jakarta-commons-fileupload
Announcement ID: SUSE-SU-2014:0548-1
Rating: important
References: #862781
Affected Products:
  • SUSE Linux Enterprise Server 11 SP3 for VMware
  • SUSE Linux Enterprise Server 11 SP3

  • An update that fixes one vulnerability is now available.

    Description:


    This update fixes a security issue with
    jakarta-commons-fileupload:

    * bnc#862781: denial of service due to too-small buffer
    size used (CVE-2014-0050)

    Security Issue reference:

    * CVE-2014-0050
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Server 11 SP3 for VMware:
      zypper in -t patch slessp3-jakarta-commons-fileupload-9087
    • SUSE Linux Enterprise Server 11 SP3:
      zypper in -t patch slessp3-jakarta-commons-fileupload-9087

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Server 11 SP3 for VMware (noarch):
    • jakarta-commons-fileupload-1.1.1-1.37.1
    • jakarta-commons-fileupload-javadoc-1.1.1-1.37.1
    • SUSE Linux Enterprise Server 11 SP3 (noarch):
    • jakarta-commons-fileupload-1.1.1-1.37.1
    • jakarta-commons-fileupload-javadoc-1.1.1-1.37.1

    References:

    • http://support.novell.com/security/cve/CVE-2014-0050.html
    • https://bugzilla.novell.com/862781
    • http://download.suse.com/patch/finder/?keywords=ba380f7e3fc44242f7f8d403bdc016a6