Security update for libssh2

SUSE Security Update: Security update for libssh2
Announcement ID: SUSE-SU-2014:0413-1
Rating: moderate
References: #866278
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11 SP3
  • SUSE Linux Enterprise Desktop 11 SP3

  • An update that fixes one vulnerability is now available.

    Description:


    This update of libssh fixes the following security issue:

    * When libssh operates in server mode, the randomness
    pool was not switched on fork, so two pools could operate
    on the same randomness and could generate the same keys.

    Security Issue references:

    * CVE-2014-0017
    >

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11 SP3:
      zypper in -t patch sdksp3-libssh2-8982
    • SUSE Linux Enterprise Desktop 11 SP3:
      zypper in -t patch sledsp3-libssh2-8982

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 ia64 ppc64 s390x x86_64):
    • libssh2-0.2-5.20.1
    • SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):
    • libssh2-0.2-5.20.1

    References:

    • http://support.novell.com/security/cve/CVE-2014-0017.html
    • https://bugzilla.novell.com/866278
    • http://download.suse.com/patch/finder/?keywords=c5defdb274ad752516b657c99cbfbe26